Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just a heads up, everything here is being done in Ubuntu, just because I already had a PPC disk. Later when I have a better internet connection, I'll use Lubuntu, but this was quicker. I have a PowerMac G5 dual Core, with the default graphics card, the Radeon 9600. Great for low shaders, however I cannot seem to get the driver working. For starters, when I click on "Additional Drivers" within the System Settings, it flashes a window, appears in the launcher, then disappears. So, from the ATI site, I downloaded the 32 Bit Driver in the form of a .run file. I made sure it was an executeable and then ran in through terminal. It seemed to verify and uncompress, however the installer ran into an error, and before I could read it, the window closed itself. Trying through another method I found the error to be:

Error: Distro Version entered incorrectly or not supported, use --listpkg to 
identify valid distro versions
Error: Distro Version entered incorrectly or not supported, use --listpkg to  
identify valid distro versions
Removing temporary directory: fglrx-install.edUSIT

Does anyone think that the graphics card would be able to secure a driver even though the architecture that the OS is currently running in is commonly unsupported? Or has anyone else found a way to run the driver for this graphics card correctly?

It has come to my attention that the driver may not have been released with PPC support, therefore that may be my problem. Can anyone confirm this?

share|improve this question
1  
Have a look at the q & a askubuntu.com/questions/124292/what-is-the-correct-way-to-install-ati-catalyst-v‌​ideo-drivers/126513#126513 –  Stephen Myall Jul 5 '12 at 0:57
    
Thanks, I'm going to check that out. –  etsr Jul 5 '12 at 1:41
    
12.6 Doesn't support PPC64 Architecture. –  etsr Jul 5 '12 at 2:47
add comment

2 Answers

http://support.amd.com/us/gpudownload/linux/Legacy/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.12&lang=English

you just have to use the radeon driver from the official repository, your card is not supported by the fglrx driver.

share|improve this answer
    
Do I just mark as executable and run in Terminal? –  etsr Jul 5 '12 at 0:32
    
Did not work, the driver gives me an error and the window closes. I'm assuming it's the same error, because the directory is removed. –  etsr Jul 5 '12 at 0:38
1  
@Flabricorn at the end of that page that i have linked there is a download option for a legacy fglrx driver, try to use that one, remember that every legacy driver could be unsupported by todays kernels, also remember to uninstall the previous driver each time you want to install something new. –  user827992 Jul 5 '12 at 10:24
    
That's the download I used... How could I install the other drivers? None of the other installers to my knowledge worked or installed anything. –  etsr Jul 5 '12 at 12:52
1  
Error: Error: ./default_policy.sh does not support version default:v2:ppc64:lib::none:3.2.0-26-powerpc64-smp; make sure that the version is being correctly set by --iscurrentdistro Removing temporary directory: fglrx-install.8AJLf5 –  etsr Jul 5 '12 at 14:44
show 3 more comments
up vote 0 down vote accepted

I cannot use the driver because of Power PC architecture issues. Thanks for all the help everyone!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.