Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm looking into Xmonad. One problem I'm having is that most of my applications in Xmonad don't have anti-aliasing.

For example gnome-terminal & evolution. I have this in my .Xresources:

Xft.dpi: 96
Xft.lcdfilter: lcddefault
Xft.antialias: true
Xft.autohint: true
Xft.hinting: true
Xft.hintstyle: hintfull
Xft.hintstyle: slight
Xft.rgba: rgb

And this in my .gtkrc-2.0:

gtk-theme-name="Ambiance"
gtk-icon-theme-name="ubuntu-mono-dark"
gtk-font-name="Sans 10"
gtk-cursor-theme-name="DMZ-White"
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_BOTH
gtk-toolbar-icon-size=GTK_ICON_SIZE_LARGE_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle="hintfull"
gtk-xft-rgba="rgb"
include "/home/leon/.gtkrc-2.0.mine"

But I still have no anti-aliasing. When I launch gnome-settings-daemon I do get anti-aliasing. But I don't want to run gnome-settings-daemon.

What could be the problem? I'm running Ubuntu 12.04 Desktop.

share|improve this question
add comment

3 Answers 3

You have conflicting directives in your .Xresources. Try removing one of the two lines:

Xft.hintstyle: hintfull
Xft.hintstyle: slight

And see if that works. I used exactly your .gtkrc-2.0 and .Xresources on a relatively unmodified Xmonad setup on Ubuntu 12.04, and the setting worked correctly once I removed one of those lines.

share|improve this answer
add comment

Have you tried running this to make sure that your .Xresources changes are getting applied?

xrdb -merge .Xresources
share|improve this answer
    
Yeah, I tried that. In the meantime I also rebooted several times and that didn't work either. –  Leon Jul 5 '12 at 8:46
1  
Next question: what video hardware do you have and which drivers are you using? The reason I ask is to determine how closely your setup matches mine so we can start eliminating variables. –  dbrewer Jul 5 '12 at 22:28
    
I don't think it's something with the hardware. Every other wm behaves correctly. But for completeness: I have a Sandy Bridge/optimus (?) with bumblbee installed. The Intel driver is the default one: i915 I believe. –  Leon Jul 6 '12 at 23:55
add comment

Make sure that gnome-settings-daemon is running.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.