Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In previous Ubuntus (GNOME, not unity) I could add "--incognito" to the end of the executable file command of Chrome to make Incognito default.

I cannot find an executable file for Chrome in 12.04. How do I make Incognito default for Chrome in 12.04?

share|improve this question
add comment

3 Answers

This is how I do it using alacarte (main menu). Install alacarte (aka main menu) from the Ubuntu Software Center if you don't already have it. Launch it.

On the left hand side, under Menus, make sure Applications is expanded. Look for Internet. Single click it. Now look for Chrome under Items. Single click it. Look for Properties on the right hand side. Single click it. A little window appears. (I've dragged it to the right for clarity.) Look for Command. For me, I see /opt/google/chrome/google-chrome %U.

using alacarte

Carefully change that to: /opt/google/chrome/google-chrome --incognito %U

Click Close on the little window and then click Close on the Main Menu window. You need to log out and log in to make the change register.

You're done.

(I just did it so I know it works.)

share|improve this answer
add comment

You need create a Chorme incognito.desktop file like with the following contents,

#!/usr/bin/env xdg-open
[Desktop Entry]
Version=1.0
Name=Chorme incognito
Exec=/opt/google/chrome/google-chrome --incognito
Terminal=false
Icon=google-chrome
Type=Application
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml_xml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;

save this file, open a nautilus with root permission. (run gksu nautilus)

Browse to /usr/share/applications and paste the file here.

Now you can drag this icon to your launcher.

Click on launcher icon, chorme will start in incognito mode.

share|improve this answer
    
Can't one just use ala carte (main menu) to do this via a GUI? –  user25656 Jul 4 '12 at 17:33
add comment

I prefer simply setting CHROMIUM_FLAGS in /etc/chromium-browser/default:

CHROMIUM_FLAGS="-incognito"

Works on Ubuntu 12.04

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.