Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I saw in default gnome theme icons when I clicked right the mouse. The icons are very useful for orientation in the menu.
See the picture below. How can I add some icons to standard ubuntu theme?

If there no icon pack how can I add my own icons?

alt text

share|improve this question
    
Hmmm. Mine do show up. I wonder what's up with this. –  Clay Smalley Dec 2 '10 at 23:49
    
@Clay are you using < 9.04? –  Marco Ceppi Dec 3 '10 at 2:27
add comment

2 Answers 2

up vote 7 down vote accepted

You can enable this option (It's disabled by default) in the configuration manager. This should be available through Applications -> System Tools -> Configuration Manager (The System Tools menu may be hidden - you can make it visible by going to System -> Preferences -> Main Menu and selecting the checkbox next to System Tools, and possibly the one next to Configuration Editor in side the System Tools menu). Alternatively you can run gconf-tool from the command line.

You'll need to navigate to desktop -> gnome -> interface

alt text

Select menus_have_icons and check the box.

If you want the quick one liner you can enter the following in your terminal

gconftool --set --type bool /desktop/gnome/interface/menus_have_icons 0

This is the outcome

alt text

share|improve this answer
    
I think you mean gconf-editor instead of gconf-tool. –  vrcmr Dec 3 '10 at 20:26
add comment

See comment 4 for bug 974915 "Nautilus Context menu missing icons".

Sebastien Bacher wrote on 2012-04-06:

icons for most components got turned off like 2 years ago, they are only there in menu for objects like applications or directories, not for actions etc

Sebastien Bacher wrote on 2012-04-09:

it's not a bug, it's a design decision

But the following tip works!

  1. Execute Alt+F2 → run gnome-tweak-tool
  2. Navigate to "Theme" settings
  3. Enable icons in Context menus using the sliders "Menus Have Icons" and "Buttons Have Icons"
  4. Restsart Gnome Shell doing Alt+F2r
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.