Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm configuring a "network", between two computers(both with ubuntu 12.04), using a crossover cable and assigning all ips by hand. When I set up an interface, with IP netmask etc, everything works, but in less than a minute ubuntu remove all my configuration and shows a message saying "activation of network connection failed". My guess is that it is trying to get the IPs via DHCP, but I'm not using anything of that. Anyone knows some way to disable that automatic configuration?

share|improve this question
    
How are you assigning the IPs?. Are you using Network manager?. –  Javier Rivera Jul 4 '12 at 14:30
    
I'm using ifconfig iface address ... –  CEAFDC Jul 4 '12 at 14:32
add comment

1 Answer

In Ubuntu the network configuration is managed by Network Manager. As you suspected, if you change your IP by hand (using ifconfig), as soon as it detects the change it will revert it.

You can either disable it or use it to change the ip configuration.

To disable Network Manager:

  • From the GUI, click on the network icon, uncheck activate network.
  • From the commnad line : nmcli nm enable false

Or to stop the service

sudo service NetworkManager stop

You can use nmcli to control Network Manager from the command line, including creating new connections or changing between them. Or you can just use the GUI, click on the network icon and select edit connections. There, you can either change the default connection or add another one with a fixed IP.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.