Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I cannot force clock in Gnome Classic to show seconds. Tried within dconf-editor, changing all available clock settings:

com > canonical > indicatior > datetime There I was trying by changing custom-time-format and setting time-format to custom and by checking show-seconds. Both does not work.

org > gnome > desktop > interface I turned clock-show-seconds on. Nothing happened.

org > gnome > gnome-panel > shell > clock show-seconds enabled, no reaction.

Also, I've been restarting system after each change.

Please, help - I need it for few things.

enter image description here

I'm using Ubuntu 12.04

share|improve this question
1 works for me. What version of ubuntu are you using? Are you using the indicator-complete applet or the gnome-applets? If you are unsure - please add a link to your question with a screenshot of your desktop. Thanks. – fossfreedom Jul 4 '12 at 18:57
Oh, I forgot, Ubuntu 12.04. – Sebastian Potasiak Jul 7 '12 at 11:45
I have set seconds on in all possible places same time and still no effect. – Sebastian Potasiak Jul 11 '12 at 18:09

2 Answers 2

up vote 7 down vote accepted

This is an unusual issue - for myself, this works using dconf-editor

dconf-tools Install dconf-tools

enter image description here

Possibly you need to reinstall the package indicator-applet-complete

sudo apt-get purge indicator-applet-complete
sudo apt-get install indicator-applet-complete

logout and login and then use dconf-editor as described above.

share|improve this answer
It works for me. I did this in dconf-editor, but i didn't reinstall indicator-applet-complete, but after that, everything works fine. Thanks a lot. – Sebastian Potasiak Jul 11 '12 at 18:54

I had similar problem with Lubuntu, and all I did was right-click on clock and opened it's settings. No matter how simple the dialog box is, you should always be able to see "Clock Format" and "Tooltip Format" fields.

In first one, all you have to do is type %H:%M:%S, and that's it. H stands for "Hours", M for "Minutes", and S for "Seconds".

Now, if you are not used, like myself for example, to American date format, which is month/day/year and can be really confusing, you can also change that in the second field. Type %A %d.%m.%y.. A stands for name of today's day, d for "day", m for "month", and so on.

Instead of dots, you can put anything else, like /, or -, depends on what you prefer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.