Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to start by saying that I am very new with Linux (about 1 month using it). I have had no problems up until now.

I am running Ubuntu 12.04 from a Toshiba laptop with 250 GB hard drive and 3 GB of ram.

Everything worked fine yesterday. The only changes I made was was that I downloaded Banshee to try as a replacement for Rhythmbox and did a few recommended updates. This morning I tried to boot and it took a long time and I finally got this error:

mount: mounting /dev/disk/by-uuid/02bc41cc-1e21-4700-a179-be2805a658c4 on /root failed: Invalid argument
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have requested /sbin/init.
No init found. Try passing init= bootarg.
BusyBox v1.18. (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
Enter 'help' for a list of built-in commands
(initramfs)

I'm not sure what to do beyond this point. I have read around on here and haven't found the help I need. I did try to boot it from the Live CD. I can boot up to the Try Ubuntu/Install Ubuntu screen. When I go through the Try Ubuntu selection I can't access my hard disk. When I clicked on it I got this error:

Unable to mount 247 GB Filesystem
Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sda/1, missing codepage or helper program, or other error. In some cases useful info is found in syslog - try dmesg|tail or so.

I tried dmesg|tail and saw a string of values but nothing that looked helpful.

I have also tried to boot from the GRUB screen as recovery mode and previous Linux version but they didn't work either.

I tried to load Windows Recovery Environment (loader) (on /dev/sdc3) and got this message:

error: no such device: 268057B1805785E9
error: hd1 cannot get C/H/S values

I had saw somewhere that I could fix this with the Live CD but my knowledge isn't good enough to try. I tried something with Gpart that I had read, but the system told me that I didn't have Gpart. Could someone please explain to me what I need to do and/or haven't tried yet.

share|improve this question
    
Also I don't know if it matters, but a couple nights ago I was watching a movie on it and the power strip got turned off. This resulted in the laptop suddenly dying while playing the movie. I rebooted it just fine, but didn't know if this was helpful. –  Marty Jul 4 '12 at 17:39
    
It seems to be fixed now!! I used the Live CD to and selected Try it. From there I followed the instructions in the Boot-Repair (help.ubuntu.com/community/Boot-Repair) utility. It installed everything, ran, fixed it, and rebooted just fine. –  Marty Jul 4 '12 at 18:44

1 Answer 1

up vote 3 down vote accepted

Ubuntu Boot-Repair solves the problem!

share|improve this answer

protected by Community May 5 '13 at 20:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.