Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I get Unity working under an ATI Radeon X1600 PCI-E on Ubuntu 12.04? I'm rather Windows guy, but I can do some things with CLI.

ATI seems to have ended support for this card for both Windows and Linux. Theres no proper driver in jockey; binary driver from Software Center doesn't give Unity, just Unity 2D.

Yes, I've tried the commands from this post - without any positive results; should I try installing drivers manually?

share|improve this question
    
What have you tried so far? What do you mean by "fully working"? What is the actual problem? "get it to work" does not describe the problem you have with the graphics card. Have you tried the commands from this post? askubuntu.com/questions/153474/… -- did you try with unity 2d instead of unity? –  medigeek Jul 4 '12 at 13:15
    
I mean, i want full support for Unity/3D and for what i readed so far, ATI ended support for this card for both Windows and Linux. Theres no proper driver in jockey; binary driver from Software Centre doesnt give Unity, just Unity 2D. Yes, ive tried the commands from mentioned post - without any positive results; should i try installing drivers manually? –  user74975 Jul 4 '12 at 13:36
    
Have a look at this Q&A askubuntu.com/questions/124292/… –  Stephen Myall Jul 5 '12 at 8:19

1 Answer 1

The best way to get this card running is to do nothing; Ubuntu ships with fully functional drivers for this (and virtually all AMD) card(s).

Some people with newer cards may want to install the AMD proprietary fglrx drivers; they offer somewhat improved OpenGL performance and features, as well as better power management, but sometimes have annoying bugs. Sometimes they have support for newer cards than the default Ubuntu drivers, too.

As you've found out, AMD has dropped support for your card in fglrx, so that option is not available to you. To make matters worse, installing fglrx will disable the default drivers, so trying to do so won't improve things ☺.

Uninstall fglrx and you'll get 3D working again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.