Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When using Ubuntu 12.04 i've aquired the need to use the system Alert Sounds.

I've been trying to make my SSH Shell play Alert Beeps ( "\a" ) back to me, but to no avail, I finally figured out that it's not the ssh session itself, but the Alert Sounds altogether.

I've tried almost all the solutions out there, these have no result

Ubuntu Tweaks
echo -e "\a"
Turning up the volume in System Settings -> Sounds -> Sound Effects
/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"
beep
Changing the default Alert Sounds set to Ubuntu
Copying files in /usr/share/sounds/ubuntu/stereo to /usr/share/sounds

What i have noticed

/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login"

returns "Option parsing failed: Cannot open display:"

echo $DISPLAY

returns ":0"

Going into System Settings -> Sounds -> Sound Effects and clicking on a sound makes it play, but when actually asking for the alert sound it wont play

The sounds wont play in "Guest" or other users either.

I'm using Gnome-Classic from package Gnome-Shell, but it also does not work in the default unity shell

Everything I have tried to get it to work returns no sounds whatsoever

Can anyone help me out with this one? I'm completely lost as to what else to try

share|improve this question
    
I think you're looking for a system alert sound. Have you tried this? askubuntu.com/questions/86502/re-enable-popping-sounds –  medigeek Jul 4 '12 at 10:50
    
Or answers from this question? superuser.com/questions/47564/… Looks like pcskpr module is required –  medigeek Jul 4 '12 at 10:58
    
@medigeek That's exactly what i'm looking for, they're the "Alert Sounds" but they dont work at all. and i have indeed tried that. and the superuser link is NOT what i want, i want the local Alert Sounds to play, as i said, echo -e "\a" locally does not play –  KsaRedFx Jul 4 '12 at 20:05
    
Hey, here's another one unix.stackexchange.com/a/1979/16013 -- According to this answer "this may not work when logged in remotely via SSH" (or this answer for the "theory" unix.stackexchange.com/a/1980/16013 ) –  medigeek Jul 4 '12 at 20:44
    
Maybe you should try other terminals? Like xterm? –  medigeek Jul 4 '12 at 20:48

1 Answer 1

Try:

sudo modprobe -v pcspkr 

Then this should make a sound:

echo -e "\a"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.