Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Very recently, my kernel was upgarded from 3.2.0-25-generic to 3.2.0-26-generic through Update Manager. Since then, my google chrome cannot be opened up as usual from Dash Home or command line (google-chrome) although I can see it sleeping in the System Monitor. Now I have to run Google Chrome using command

google-chrome --disable-bundled-ppapi-flash

but have to sacrifice Flash function. How to open it up as normal? The detail info of my computer are as follow:

google-chrome-stable 20.0.1132.47-r144678

Distributor ID: Ubuntu
Description:    Ubuntu 12.04 LTS
Release:    12.04
Codename:   precise

3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 16:26:01 UTC 2012 i686 athlon i386 GNU/Linux

processor   : 0
vendor_id   : AuthenticAMD
cpu family  : 6
model       : 10
model name  : AMD Athlon(tm) XP 2500+
stepping    : 0
cpu MHz     : 1837.000
cache size  : 512 KB
fdiv_bug    : no
hlt_bug     : no
f00f_bug    : no
coma_bug    : no
fpu     : yes
fpu_exception   : yes
cpuid level : 1
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
bogomips    : 3681.99
clflush size    : 32
cache_alignment : 32
address sizes   : 34 bits physical, 32 bits virtual
power management: ts
share|improve this question
    
Try Killing the sleeping process of chrome. Also after starting Chrome from your method , go to chrome settings , advanced settings, and Untick the Background Apps optioned menu if it is ticked. –  atenz Jul 4 '12 at 6:29

1 Answer 1

The bug is not specifically in Chrome--it's a Flash issue. The latest version of Flash for all browsers--Firefox, Chromium and Chrome--all have SSE2 coding which isn't supported by older pre-2003 AMD Athlon CPU's. Both Adobe and Google are aware of this. Adobe has said its not an issue they plan to fix, as support is dropped and only security updates are still being released.

Looking at the your CPU info, there no support for SSE2 in flags, as is the case on my system and millions of others.

My advice to get a Flash functioning browser would be to uninstall Adobe Flash and Chrome and install the v19 chrome deb. This is the last known working version of Chrome for any browser for Linux systems with no SSE2 capability.

Run cat /proc/cpuinfo in a terminal. Look for SSE2 in flags. If your CPU has no SSE2, the latest version of Adobe flash will not display Flash in any browser. Chrome version 20 which is the latest stable will also not start.

The workaround, for the moment, is to install Version 19 of Chrome as this used the last (NPAPI) version. The issue appears to only affect the PepperFlash built into Chrome 20.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.