Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 12.04 LTS on a PowerMac G5 and I have one problem. My wireless PCI card has my "Firmware Missing". I already know about Broadcom's poor wireless support with Ubuntu, and it's b43 however whenever I try to install the b43 firmware installer I get this:

snackadoodlepop@snackadoodlepop-desktop:~$ sudo apt-get install firmware-b43-installer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package firmware-b43-installer

NDIS Wrapper won't work on PowerPC to my knowledge. I'm stuck without WiFi and I need help!

SOLVED: Thanks to reddit's /r/linuxquestions, I was able to use the b43 firmware installer correctly.

share|improve this question
    
Yo, I got your email. I'll be flying blind, but I'll try and come up with something for you. –  jrg Jul 4 '12 at 2:55
    
Hey, thanks so much, I got it though I didn't apt-cache search b43 which fixed it! –  etsr Jul 4 '12 at 23:08
    
So you installed the firmware-b43-installer package, right? –  jrg Jul 4 '12 at 23:36
    
Yes, and now the wireless card works without a USB for WiFi. –  etsr Jul 4 '12 at 23:46

2 Answers 2

spent 2 days and nights trying to set up Ubuntu on my Ibook G4. wireless would not work. I did what said. Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo apt-get update && apt-cache search b43

then

sudo apt-get install firmware-b43-installer

you will need to type "y" to confirm disk space is used then it worked

share|improve this answer
up vote 1 down vote accepted

You need to:

sudo apt-get update && apt-cache search b43 

To find the firmware package. Then again:

sudo apt-get install firmware-b43-installer

You have wireless (but might need to restart first).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.