Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Gparted and all my ntfs file systems have become read-only.I tried the solution given here How to change permissions to the other drives in a hard disk?, using pysdm, but I'm unable to change file system from read only. Changing /etc/fstab as indicated in the same post gives me an error. Please help.

Is there any other way of rectifying this problem?

share|improve this question
    
I found this on the web but I'm not able to comprehend it.linuxquestions.org. Do I have to install ntfs-3g to rectify it? –  u6844 Jul 3 '12 at 17:47
    
will removing gparted help? I don't want to try removing it before I'm sure that things can't be reverted back to normal using gparted. –  u6844 Jul 3 '12 at 17:52
    
make sure you are using ntfs-3g, otherwise it might not work. –  Thomas W. Jul 3 '12 at 18:44

2 Answers 2

up vote 1 down vote accepted

Install NTFS configuration tool and when you open it for first time you will get an option to enable write support on NTFS partitions you have - internal or external.

You can also select which partitions you want to enable support by default.

For example, I have three NTFS partitions - one of which is Windows 7 C: drive and one other is Windows 7 boot loader partition. I enabled write support only for C: drive and not the bootloader by default. Doing this will also auto-mount the partitions for you (by the time Ubuntu boots up). You don't need to mount them each time, if you use this tool.

Go to Software Center and search for NTFS and you will find this one in the list. Just install it and open it, you will understand what to do. I use Gparted too, but I don't think that the problem is with Gparted or something else. NTFS partitions give some trouble sometimes.

Read these for more explanation if the software center doesn't show NTFS tool in its repositories (which I think might be the case with 11.10):

How do I enable NTFS write support?

Adding NTFS-Write capability by default

share|improve this answer
    
I have 2 ntfs partitions that's working just fine by the method that you suggested. Thanks a lot for that. However, its not working with windows ntfs partition. I get this message "Error mounting: mount exited with exit code 1: helper failed with: Unprivileged user can not mount NTFS block devices using the external FUSE library. Either mount the volume as root, or rebuild NTFS-3G with integrated FUSE support and make it setuid root. Please see more information at tuxera.com/community/ntfs-3g-faq/#unprivileged";. What should I do? Thanks in advance. –  u6844 Jul 4 '12 at 4:16
    
I was reading about modifying /etc/fstab. So I tried commenting the lines which related to mounting of windows ntfs partition, and the problem is fixed now. Please tell me whether that will have repercussions on something else. –  u6844 Jul 4 '12 at 4:22
    
@GK: Well, if your Ubuntu is booting properly and if all partitions are working properly, I think there would be no more problems with the partitions. I think you might have read this, but take a look at this question for double check.askubuntu.com/questions/120233/… Also, read a little about /etc/fstab file to make sure you have done things properly. If you come across some problems in future, you will be able to solve them on your own next time if you read about it. Check this out: tuxfiles.org/linuxhelp/fstab.html –  Forbidden Overseer Jul 4 '12 at 7:05
    
ForbiddenOverseer, you rock, just like the guy on your display pic :). Thanks a ton! –  u6844 Jul 4 '12 at 10:29
    
@GK: Woah.. spare some praises for yourself too!! TBH, I am also learning here because of you... :) –  Forbidden Overseer Jul 4 '12 at 13:32

Try uninstalling GParted. Also, try to remember what you did to NTFS partitions using GParted and reverse those actions if possible. I had a configuration quite similar to yours (11.10, GParted installed, and an NTFS partition auto mounted via pysdm). All worked together perfectly.

share|improve this answer
    
I did not make any changes using GParted. I'll see if removing GParted helps. Thank you. –  u6844 Jul 3 '12 at 17:59
    
also (forgot to mention it yesterday) look again at your pysdm settings, for by default it mounts NTFS partitions in RO mode. you need to uncheck that option manually. –  Kom-Si Jul 4 '12 at 20:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.