Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install updates with update manager I get this message

The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems.

Furthermore run the following command in a Terminal: `apt-get install -f`

The following packages have unmet dependencies:
libc6-dev:i386: Depends: libc6 (= 2.15-0ubuntu10) but 2.15-0ubuntu10 is installed
                Depends: libc-dev-bin (= 2.15-0ubuntu10) but 2.15-0ubuntu10 is installed

And when i type in apt-get install -f I get this answer

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

What to do?

share|improve this question
1  
Try sudo apt-get install -f (this gives you "root" permissions) –  8128 Jul 3 '12 at 16:19

1 Answer 1

To get root permission use sudo and then the command, like this >> sudo apt-get update OR sudo apt-get upgrade OR in your case you have to use sudo apt-get install -f.

By the way if you get an error when you type in the sudo apt-get update command regarding /var/lib/dpkg/lock run this command sudo killall apt-get and if you still get the error, then run this command sudo rm /var/lib/dpkg/lock and you should be able to update successfully the next time you try sudo apt-get update

Hope it helped :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.