Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a 1TB hard drive from a friend which doesn't work as it should. When plugged into my Ubuntu laptop, hard drive label is shown on nautilus, when clicked, error message pops out:

Error mounting: mount exited with exit code 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

sudo fdisk -l shows

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x9cf4ffb0

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048  1953523119   976760536    7  HPFS/NTFS/exFAT

My laptop has only 250GB, so it seems I can't use ddrescue etc. I only have WinXp on Virtualbox, I tried starting up windows with the hard drive mounted and type chkdsk \f from cmd, but it looks like it's going to check the NTFS partition of C: but not the removable hard drive. Tried ntfsck and ntfsfix before, no vail. Urgently need some advice on how to fix the removable hard drive, if not possible then how to (selectively) backup data into readable format?

share|improve this question
    
You might have bad sectors on the drive. If it won't mount, then that's usually a hardware problem. (unrelated: for Winodws, in cmd prompt, cd [driveLetter]:\ , then chkdsk \f) –  Thomas W. Jul 3 '12 at 16:04
    
@LordofTime seems it won't mount on Windows, didn't appear on My Computer –  Ivy Lee Jul 3 '12 at 16:06
    
then its likely the drive is bad, or dying. either that, or the enclosure for the disk is dead. Normally, when I see I/O errors, they indicate some type of hardware failure, especially if the drive won't mount in any OS/ –  Thomas W. Jul 3 '12 at 16:08

1 Answer 1

up vote 0 down vote accepted

Do not let your linux host take control to the device, make sure have it attached directly to the vbox Windows.

To do so, in the vbox system's Setting->Usb, Click 'Add Filter from Device', choose your HD, click OK. Then unplug the USB, wait 10s for the whole hardware reset, then replug in, then the device should be automatically attached and handled by the virtual windows, if ideally, it can be recognized as a drive, and then try CHKDSK X: /f in the windows command line.

This applies to a partition with some status error, while ntfs-3g can not fix.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.