Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I run sudo apt-get install tortoisehg-nautilus under Ubuntu 12.04 I get:

E: Unable to locate package tortoisehg-nautilus

The same command works under Ubuntu 10.04 and I get full nautilus integration. I tried installing tortoisehg and using the ppa:tortoisehg-ppa/releases PPA but I don't see any nautilus integration. Right clicking on folders does not bring up a TortoiseHg menu item, nor do I see icon overlays for Hg repositories. Any ideas?

share|improve this question
up vote 4 down vote accepted

According to this bug on the tortoisehg tracker, there was an issue with nautilus integration. It appears to be fixed in the upstream version now. This is likely something worthy of getting an update for precise to fix the bug.

Try installing the package as a one-off installation from quantal. Here's a direct link to the current deb package. This may get updated, so if it fails, use the ubuntu package search to find the current version and install it that way. If that doesn't work, you can apply the patch mentioned manually in the bug report.

share|improve this answer
FYI: this was removed in Precise. It no longer exists in the repositories. – Thomas Ward Jul 3 '12 at 16:09
@LordofTime It is back in Quantal – 8128 Jul 3 '12 at 16:47
@fluteflute the reason i mentioned it was removed from Precise was so that "getting an update for precise" wouldnt mean additional bug reports for updates (because it doesnt exist in Precise). As well, any updates or sync requests or backports will need extensive testing to be included in Precise. – Thomas Ward Jul 3 '12 at 16:52
@LordofTime: What was removed in Precise? The "tortoisehg-nautilus" package? Why? Where should I ask? :) – Gili Jul 3 '12 at 17:07
@Gili, the package you're looking for was removed in Precise. I do not know why it was removed, nor do I know where you should ask. but what fluteflute said is right, it is in Quantal. – Thomas Ward Jul 3 '12 at 17:12

The link is not working anymore...

So try this :

Pick a mirror of your choice.

Then install the package. In my case the installation failed, but the nautilus integration start working.

share|improve this answer
I recommend updating the link in the accepted answer. – Gili Jan 4 '13 at 23:12
It failed for me as well, something about a python script that already existed, but it works fine. – M Granja Jan 31 '13 at 16:30
@Gili, I would add commment on the accepted answer, but I don't have reputation for that yet :( – Richard Feb 4 '13 at 14:57
I thought maybe we could create a PPA for tortoisehg-nautilus... I don't know how to do it, but I could read a bit about that. It must be just a repackaging of the Quantal package since it just a single python file that is contained in this package... – Richard Feb 21 '13 at 19:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.