Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've followed this tutorial from this blog which very clearly explains how to connect Android phone with ICS to Ubuntu so that one can access phone's sdcard (MTP access).

I passed all the procedure with no errors, I can event attach my mobile to ubuntu via

mtpfs -o allow_other ~/Android/GalaxyS2

and disconnect via

fusermount -u ~/Android/GalaxyS2

The problem comes when I try to access mounted directory. If I try to do it via Nautilus, the system tries to open the folder for a couple of minutes and then, I either see the error, or the folder disappears from Nautilus (it comes back when I disconnect the path).
I also get a console error:

fuse: bad mount point `~/Android/GalaxyS2': Transport endpoint is not connected

I see many people on the net reporting this error, but no-one offers any solution to it.

I use Ubuntu 11.10 with Gnome Shell (Gnome 3) and the mobile is Samsung Galaxy S II.

I am in the fuse list, I did all the steps in the tutorial dozens of times, all in vain.

share|improve this question
add comment

4 Answers 4

up vote 7 down vote accepted

Please note the Terence Egan Blog where you took the instructions from is a copy of an OMG Ubuntu article.

He has missed an important step to restart your PC before running the Echo commands I suggest you try and reinstall from the original OMG Ubuntu source. Click on this link

share|improve this answer
    
Oh my god!!! I did not know that. Will do this asap. –  ubuntico Jul 3 '12 at 16:40
    
It worked this way. I connect the mobile and them immediately (under 1s after connection) I have to start command android-connect. Otherwise, the system will try to mount the mobile and after that I cannot use fuse to mount it. It the same with you? –  ubuntico Jul 3 '12 at 17:08
1  
My suggestion as you have one issue resolved. Is to close this question, open a new question stating what has worked successfully, state the fuse issue an share a screen shot of the issue. That way the question has more focus and cleaner for others to benefit from the answer –  Stephen Myall Jul 3 '12 at 17:39
add comment

You do not need to use MTP on the Galaxy S2 as you can use USB mass storage. Before connecting the phone via USB cable do the following:

  • go to the settings
  • under Wirless and network click on "More"
  • select USB utilities
  • click the "Connect storage to PC"

Now you can plug in the USB cable and use USB mass storage.

On more modern versions of Android, you may need to click the "More…" item in settings. This contains the "USB Utilities" item, mentioned above.

share|improve this answer
    
The OP has specified Android-4.0 ICS. Do you mean that Samsung has kept USB mass storage support in their ICS ROM for the Galaxy S2 ? –  m-ric Feb 27 '13 at 16:09
add comment

It ever worked for me, I kept getting the error message "transport endpoint is not connected" until I entered the connection command (mtpfs -o allow_other /media/GalaxyNexus) as a startup application. Now I get the device and the SD card mounted with no problem.

share|improve this answer
add comment

This worked for me:

I connect the mobile and them immediately (under 1s after connection) I have to start command android-connect.

The command is:

mtpfs -o allow_other /media/SamsungOmniaW/

Otherwise, the system will try to mount the mobile and after that I cannot use fuse to mount it. It the same with you?

Certify the USB to PC connection is Media Device (MTP), because you are using "mtps" commands.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.