Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log in, either Unity loads perfectly or it just doesn't; all I see is my desktop background. Commands don't seem to work and I can't switch to the terminal view. No matter how long I wait, Unity doesn't start. I never had this issue with Oneiric Ocelot.

Other GUIs such as GNOME 3.4 don’t seem to be having that issue. I've got MyUbuntu, Ubuntu Tweaks, CompizConf and other tweaking tools installed. Could they be causing the problem? If not, what should I do? I'd really like to use Unity again.

Thanks in advance!

share|improve this question
    
Have you tried unity --reset? –  Mitch Jul 3 '12 at 13:20
    
No, I haven't tried that before but I just did. Unity launched properly twice after I reset it but I'm not sure if that's a permanent fix or not. I'll get back here if I still experienced problems. Thank you! :) –  Vagrant232 Jul 3 '12 at 16:57
    
unity --reset did not fix the issue. Starting unity is still a gamble. –  Vagrant232 Jul 4 '12 at 13:59
add comment

1 Answer

up vote 2 down vote accepted

The issue was fixed by updating to a newer Nvidia driver then resetting Unity. The issue seemingly was a conflict between Compiz and the recommended Nvidia driver. I hope this helps other people.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.