Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Precise Pangolin with GNOME 3.4. Whenever I run a WINE Application there is a chance that the application will show a black screen and a chance that it might run properly. I haven't found a way to exit the black screen besides rebooting the entire system. Ubuntu seems to be still running properly in the background but I can't access the terminal or anything else. If rhythmbox is open the music keeps playing. I didn't have this problem with the same WINE applications on OpenSUSE 12 or Oneiric Ocelot but back then I was running GNOME 3.2. The applications run smoothly on Windows 7. It's really annoying to reboot the system every time WINE displays a black screen so is I'm wondering, is there a workaround for this?

share|improve this question
Which WINE version you currently working on? What exactly do you mean by "there is a chance that the application ... " ,does it mean that only sometimes blank screen happens? – Srijan Jul 3 '12 at 11:47
Yes that's exactly what I mean! Sometimes this issue occurs and sometimes it doesn't. I'm using Wine 1.4. I downloaded it straight from the Software Centre. – Vagrant232 Jul 3 '12 at 13:01
Try upgrading it to 1.5.6 which is currently available on their site. But make sure to completely remove the previous version through terminal before installing the new version. – Srijan Jul 3 '12 at 18:47
The same problem still occurs with Wine 1.5.6. I also tried updating my Nvidia driver – Vagrant232 Jul 6 '12 at 13:52
The issue was fixed after Compiz and the Nvidia driver were updated a few times. – Vagrant232 Sep 23 '12 at 17:56

That happens to me too sometimes.

In my case I just close or exit the wine application by pressing Alt+F4. If that doesn't close wine, try pressing CTRL+ALT+F1 to switch to console mode and kill wine from there.

share|improve this answer
I can't switch to the console view, pressing Alt+f4 and CTL+ALT+F1 do nothing at all. – Vagrant232 Jul 6 '12 at 13:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.