Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed MySQL server in my local Ubuntu server (11.10). I can't connect to the server from a remote machine.

When I tried:- nmap localhost , It shows the following

PORT     STATE SERVICE
22/tcp   open  ssh
80/tcp   open  http
139/tcp  open  netbios-ssn
445/tcp  open  microsoft-ds
631/tcp  open  ipp
3306/tcp open  mysql

It means that 3306, the MySQL port is open, right? But when I tried nmap 192.168.0.50, which is the server IP, I get the following:-

PORT    STATE SERVICE
22/tcp  open  ssh
80/tcp  open  http
139/tcp open  netbios-ssn
445/tcp open  microsoft-ds

Does this mean the port is not open when accessing using IP? If so, how do I open the port?

I had tried the following code, but looks like it didn't work.

sudo iptables -A INPUT -p tcp --dport 3306 -j ACCEPT

What is wrong here?

share|improve this question

1 Answer 1

up vote 7 down vote accepted

Your MySQL service is bound to serve localhost only (interface binding). This is the default for security reasons. If you really need to access it directly from other hosts, there is a nice How to enable remote access to MySQL on Ubuntu which you could follow:

  1. as root, open your /etc/mysql/my.cnf with your favorite editor
  2. look for the [mysqld] section, and in there for the bind-address keyword. This usually is set to 127.0.0.1 -- change that to match your "normal" IP-address
  3. save the file, and reload the service (e.g. using service mysql restart)

Remember you must enable your remote users to access their database(s) from remote, by setting the appropriate GRANTs -- e.g.

GRANT ALL ON mydb.* TO remoteuser@'%' IDENTIFIED BY 'SomePASSWORD';

Note the @'%', which means "from any host".

share|improve this answer
    
Thanks for the explanation and the link. It worked. –  Sparky Jul 4 '12 at 10:02
    
Glad to read -- and you're welcome! –  Izzy Jul 4 '12 at 10:53
    
link is broken :( –  dino Jun 24 '13 at 21:44
1  
@dino No longer. I fixed that and also included an excerpt, so if it dies again the steps required are still here. My bad I didn't do so from the beginning -- but as you can see from the timestamp, that was one of my early answers. We all learn :) –  Izzy Jun 24 '13 at 22:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.