Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded my Ubuntu 11.10 to 12.04. I could not see "other" login option in the login screen. it shows only "Guest login" and "User login. The User Login ask only password and I had never entered in as User login so that I do not know about password of User login. My question is how to login as root from the login screen? how can I get "Other login" option to login as root or some other user? before asking this question I have tried the following:

  1. try to add the greeter-show-manual-login=true line at the bottom of /etc/lightdm/lightdm.conf file as Guest login but i get access denied error.

  2. i do not know the password of User login (ask only password while login) to purpose of adding above line.

  3. from the safe mode login, i could login as root but i could not add the above line the lightdm.conf file . i got read only error so that i tried to change the permission to 777 like the following chmod 777 lightdm.conf (while I am in the /etc/lightdm/ dir). but I got the error the file marked as/is read only in the file system.

  4. In 11.10 version I have created 4 users. I can see that the users exist in 12.10 . so I am sure that the user accounts are not removed in upgrade process.

In short, I need Other login option on my login screen? how to get it?

Edited Question:

I have add the following line the /etc/lightdm/lighdm.conf file on recovery mode

greeter-show-manual-login=true

and I saved the file using wq command.

now my /etc/lightdm/lighdm.conf file looking as the following:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
greeter-show-manual-login=true

if I commit any mistake please correct me. For this problem I have wasted the two working day and all the works are in pending.

share|improve this question
    
FYI, you should not log into your system as root. –  Thomas W. Jul 3 '12 at 19:10

4 Answers 4

The best way is to not use the guest account. It can't be done from the guest account. You have to use a user with sudo abilities.

  1. Open a Terminal (Ctrl+Alt+T).
  2. Run cd /etc/lightdm.
  3. Run gksu gedit lightdm.conf, which opens the configuration file in a text editor.
  4. In the text editor, add the line greeter-show-manual-login=true to the file.
  5. Save the file and close the text editor.
  6. Reboot.
share|improve this answer
    
i did it already. it list the users and ask only password to login . but my need is i should login as other that is ubuntu should ask username and password to login. thanks for your comment. –  murali Jul 5 '12 at 6:14

I have tried the following command. It has solved the other login problem:

  1. sudo passwd root
  2. sudo sh -c 'echo "greeter-show-manual-login=true" >> /etc/lightdm/lightdm.conf'.

Thanks for all who give the ideas and answer here.

share|improve this answer

You may try to login through command line. To do so, press Ctrl+Alt+F1 and do login with a user that has root privileges. Then you can modify configuration files and add those logins to the graphic login.

share|improve this answer
    
Thanks for your comment.But i do not know the User login password. i checked in the users list there is no user called "user". is User login accept my root's password?. currently i do not have my laptop my self. –  murali Jul 3 '12 at 11:13
    
Through command line you can log in with other user as you have to mannualy input your login and your password. –  laborim Jul 3 '12 at 11:21
    
please see edited question. the problem not solved. please help me. –  murali Jul 3 '12 at 18:46

When using recovery mode you need to remount the drive with write permissions using this command

mount -o rw,remount /

whilst in recovery mode, after using the above command you can change the password for the 'user' login account using the following command (replace User with the username if it is not User as stated in your question).

passwd User  

Then enter the new password twice, you will not see what you are typing.
Then reboot and login using the new password.

share|improve this answer
    
thanks buddy i will let you know. currently i do not have laptop my self. –  murali Jul 3 '12 at 11:15
    
Hi, i tried your first command mount -o rw,remount / and i have added greeter-show-manual-login=true line and saved. after restarting system i not yet get other login option. please see my edited question. i have added my lightdm.conf file. by this problem all the works is in pending. please help me. –  murali Jul 3 '12 at 18:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.