Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed the latest version of Ubuntu (12.04) on my boyfriend's new Dell XPS 15z laptop.

He uses a Microsoft wireless keyboard and mouse, and an Acer X203H monitor with his set-up. No problems with the keyboard or mouse, or with connecting the HP printer, but we just can't get the laptop to talk to the Acer monitor.

With his old setup he used a VGA cable to connect machine & monitor. New laptop has no VGA port, but we've bought a VGA to HDMI adaptor to connect to the laptop.

Have tried using Fn F2 to change the display from laptop to monitor, but it doesn't see the monitor at all. HELP! Is there a driver I can install from somewhere?

Or how can I tell Ubuntu to look for the monitor on another port? Completely in the dark, and about to get in trouble!!

Thanks

share|improve this question
add comment

1 Answer 1

First thing is XPS14Z is nvidia optimus enabled. Optimus is not supported by nvidia in linux. The bumblebee project is really helpful in power saving but still its a nightmare specially in case of multi moniter setup.

There are two kind of video chips with optimus (source)

  1. The port (DisplayPort / HDMI / VGA) is wired to the Intel chip, you do not need to do anything special to get external monitors to work in this case.

  2. The port is wired into the nvidia chip. In this case you can currently not expand the screen over monitors. The monitor may still be used as extra screen (with no desktop running on it) or to run the full desktop on it (with no output on the Intel LVDS output, a.k.a. "the laptop display").

XPS 14z has the second setup. So you can use your either your external monitor or your laptop screen.

According to your question you want Desktop on external monitor, you need to follow the below steps, (I don't have XPS 14z, all information is from here)

  1. Do not install bumblebee. If already installed , uninstall it first.
  2. install nvida-current. sudo apt-get install nvidia-current. Don't reboot.
  3. Connect the external monitor. Get the connected monitors by executing /usr/lib/nvidia-current/bin/nvidia-xconfig --query-gpu-info --nvidia-cfg-path=/usr/lib/nvidia-current

at the end line you will get something like below, figure out your monitor from there. remember the corresponding value like CRT-0. we will need it later

Display Device 0 (CRT-0):
  1. Create /etc/X11/xorg.conf. For this, press Alt+F2 and type gksu gedit /etc/X11/xorg.conf. The content should be like

Section "ServerLayout"
    Identifier "Layout0"
EndSection

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "ConnectedMonitor" "DFP"
EndSection

Change DFP to the display device number as you got in step 3.

Restart the X server (or simply reboot the system)

To restart X follow this,

  • Press Alt+Ctrl+F1 , log in using your credential.
  • type in sudo restart lightdm

If you get a black screen, please remove the config file by executing sudo rm /etc/X11/xorg.conf

Please feel free to edit this answer to add more guidance if required.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.