Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This has only happened in the last couple of days (after updates), but now my sidebar shows my two external hard disks even when they aren't mounted (or even connected for that matter). When they are connected and mounted, they are each shown twice.

For example, this is my sidebar when they aren't connected:

And when they are connected:

Is there a way to fix this?

share|improve this question
With the drives disconnected, can you right-click on the phantom icons and click on "Unlock from Launcher?" (or "Eject")? – izx Jul 3 '12 at 7:34
When I right click on the "phantom" icons, I have two options: Open or Format. It doesn't matter if the drives are connected or not. However on the two which are there when the drives are connected I get the full range of usual options. – NOP Jul 3 '12 at 7:37
What happens if you click Open (or format), for that matter? – izx Jul 3 '12 at 7:37
Nothing happens if I click either of them. I just checked that now with both drives disconnected. – NOP Jul 3 '12 at 7:39
OK, I managed to fix it. I ran unity --reset and now it's fine. – NOP Jul 3 '12 at 7:48
up vote 2 down vote accepted

Following command (with force option) could work as well: umount -f /media/Snoopy You could check what's exactly mounted by: mount command.

Try as well: unity --reset --verbose

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.