Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 12.04, the Compiz visual effects appears to be glitchy. I see a "window flash", after rotating the "Desktop Cube". I've used the "Magic Lamp effect" when minimizing windows, but the window content, minimizes faster, delaying the window border to minimize. "So the border and the window content gets apart, like in the picture below". I've tried updating Compiz, but no luck. Magic lamp minimizing issue

How to fix this problem? Will Compiz work properly in XFCE? This didn't happen in Lucid Lynx. I appriciate any help!

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

The flashing after switching workspaces is a known bug.

There seems to be only one way to get rid of it in 12.04 precise right know:

WARNING

Please be aware that activating this repository and downgrading to an officially unsupported version of compiz is not recommended. Do it only if you can't live with the flashing. You have been warned.

In a terminal, type:

sudo add-apt-repository ppa:vanvugt/compiz-preproposed
sudo apt-get update
sudo apt-get upgrade

If you are already on the latest version of compiz, you would have to downgrade to the version from this ppa to remove the flashing (e.g. by using the "force version" option (F3) in synaptic package manager).

These packages have to be installed:

libbamf3-0 0.2.118-0ubuntu0.1

libbamf0 0.2.118-0ubuntu0.1

bamfdaemon 0.2.118-0ubuntu0.1

accountsservice 0.6.15-2ubuntu9

libaccountsservice0 0.6.15-2ubuntu9

compiz-dev 1:0.9.7.8-0ubuntu1vvpreproposed2

compiz-plugins 1:0.9.7.8-0ubuntu1vvpreproposed2

compiz-gnome 1:0.9.7.8-0ubuntu1vvpreproposed2

compiz-plugins-default 1:0.9.7.8-0ubuntu1vvpreproposed2

libdecoration0-dev 1:0.9.7.8-0ubuntu1vvpreproposed2

libdecoration0 1:0.9.7.8-0ubuntu1vvpreproposed2

compiz-core 1:0.9.7.8-0ubuntu1vvpreproposed2

compiz 1:0.9.7.8-0ubuntu1vvpreproposed2

devscripts 2.11.6ubuntu1.2

evince 3.4.0-0ubuntu1

libevince3-3 3.4.0-0ubuntu1

evince-common 3.4.0-0ubuntu1

libunity9 5.12.0-0ubuntu1

gir1.2-unity-5.0 5.12.0-0ubuntu1

python-crypto 2.4.1-1

After downgrading, these packages will have to be locked to be stopped from being upgraded to their former versions right again.

A fixed version of compiz in official repositories will probably only be available in Quantal release.

share|improve this answer
    
Fantastic!! Works like a charm!!!!! Thank you very much..!!!!!!! (I just logged in to the Gnome 3 session, removed all the Compiz packages, and typed all the codes in terminal, you gave me :D) –  Naveen Jul 3 '12 at 8:10
    
Glad it worked! :) –  FuzzyQ Jul 3 '12 at 8:53
1  
Hi! I think Compiz 0.9.8, the bug free version has been released... Is there a way I can insall it on Precise Pangolin? –  Naveen Aug 19 '12 at 4:42
add comment

For Lamp effect

I've tested Lamp (actually magic lamp) effect on Unity, Ubuntu 12.04. The effects is working nicely. I think, You should upgrade your unity and compiz related packages. This should fix problems.

Desktop cube effect

You didn't mention where are using this desktop cube effect. As far as I know, "Desktop Cube" Effect is very much experimental and buggy in the Unity. If you still want to use this plugin, See this question and answer.

How to correctly enable Desktop Cube in Unity 3D

Compiz in XFCE

Compiz will not work (at least without some tricksy hack!) in XFCE, since XFCE uses another window manager called xfwm4 as their default. But if you still want to use compiz in XFCE, here is a link to do that.

share|improve this answer
    
Sorry... it didn't work. I added a screen shot... –  Naveen Jul 3 '12 at 7:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.