Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The command $ sudo apt-get install libapache2-mod-proxy-html and then $sudo service apache2 restart fires:

apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax
error on line 1 of /etc/apache2/mods-enabled/proxy_html.load: Cannot
load /usr/lib/libxml2.so.2 into server: /usr/lib/libxml2.so.2: cannot
open shared object file: No such file or directory Action 'configtest'
failed.

because 3.0.1 is buggy and apt-get offers only buggy version. So I am forced to manual install this here but it ends up to Unpacked mode (seen with $ dpkg -l|grep html). Some discussion here and more here.

The bug is also fixed in Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=670633

How to fix this? How to apply the patch/fix now so I can proceed?

share|improve this question

closed as off topic by Eliah Kagan, hhlp, Ringtail, qbi, gertvdijk Jan 27 '13 at 22:26

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
It seems to be a bug and the fix was released. see this. So, it may be closed as off-topic –  Anwar Shah Jul 3 '12 at 6:23
1  
You can check this question about getting the bug fixes. or you can discuss this on chat –  Anwar Shah Jul 3 '12 at 7:19
    
Some chatting here. –  hhh Jul 3 '12 at 18:08
    
FYI, this was fixed in Quantal. This post here however is a bug report. I will move this to the bugtrackers, and get an SRU filed –  Thomas W. Jul 3 '12 at 18:46
    
Please dpkg --remove the package, and then install it again. Paste all resulting output to a pastebin. –  izx Jul 3 '12 at 21:38
show 1 more comment

1 Answer 1

The Lord of Time solved this in a comment:

FYI, this was fixed in Quantal. This post here however is a bug report. I will move this to the bugtrackers, and get an SRU filed

The Lord Of Time July-3-12

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.