Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

This question already has an answer here:

I don't know if anyone else is experiencing something similar to this. I have an Ipod touch bought 3.5 years ago. It received the last software update a year ago. After that update I had no problems syncing it in Ubuntu 11.04 and 11.10 (two different laptops). Transfer of music albums was flawless with banshee and it would even convert files to the right format automatically.

Now, the same ipod touch, without any further software or firmware update does not work in Ubuntu 12.04 rythmbox. The device is mounted and recognized there, but when you drag/drop an album towards the device it does nothing.

Before you guys tell me to do it, yes, I have tried with Banshee and gtkpod. The first also brings up an error message saying that the ipod does not support mp3 files, and gtkpod simply crashes all the time. The result is the same.

What is going on here? Why a device that worked before does not work now in 12.04? I purchased some music in the Ubuntuone store, and would love to have it transferred to my ipod.

Please no links to outdated online manuals with older versions of rythmbox or banshee (I've read them all). And again, nothing wrong with the ipod as it worked in 11.04 and 11.10 and it has not been updated since then.

I would strongly appreciate any help provided.

thank you

share|improve this question

marked as duplicate by Radu Rădeanu, Warren Hill, BuZZ-dEE, karel, Avinash Raj Mar 13 '14 at 4:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Could you edit your question to include the particular model of iPod you're using? That could affect the problem. –  James Henstridge Jul 3 '12 at 3:19

1 Answer 1

I used Banshee and it worked fine for my ipod touch 2G ver-4.2.1. So reset your ipod touch and try out again with Banshee and have fun..Cheers.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.