Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to install JRE on my 64-bit ubuntu 10.04 installation.

Just to be sure that that is what I really want, I need to run a .jar file.

I downloaded java from this link.

Then I chose linux x64 and downloaded the tar file, I extracted it and tried to compile the source code but had the error. I don't know whether I downloaded the wrong file or I ran the wrong commands in the terminal

After I changed directory using the cd command to the extracted directory, I tried

./configure 

but I got this error:

./configure: command not found

I know that there is an easier way to install java but I just want to understand how to install an application from source in linux as it seems that I will face this problem in the future.

Thanks in advance

share|improve this question
add comment

3 Answers 3

Not sure if this works for 10.04 but here is my answer to a similar question about 12.04.

How to install Oracle Java

share|improve this answer
    
Thanks for the fast reply :_ –  user74670 Jul 3 '12 at 12:39
    
Your quite welcome. just to clarify, it did work correct? –  TrailRider Jul 3 '12 at 23:39
add comment

The stuff you are trying to download from java.com is already compiled; they're already binaries. This link contains instructions on how to install the 64-bit version, and here provides instructions for the 32-bit (i386) version.

The JRE and JDK from Oracle (the same that are on java.com) are proprietary ones, but they are known to have mostly the same source code as OpenJDK, the open-source version that is also in Ubuntu. OpenJDK is recommended to be used in Ubuntu over the Oracle one because it is officially maintained by Canonical. To install OpenJDK's JRE (equivalent to what you're trying to install now) in Ubuntu 10.04, run the following command:

sudo apt-get install openjdk-6-jre

or click here.

Note that this is OpenJDK 6, not the latest version 7. The instructions in the first paragraph are for Oracle Java 7.

share|improve this answer
add comment

Make sure that you are typing correct and the commands are for specific type

As Linux is flexible and complex don't get confuse...

To install you must follow these:

  1. find the readme or install file
  2. read that carefully
  3. if there is a sheel script then run it as root user
  4. if script dos't make good then open the script & do the function manually
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.