Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I got a Philips GoGear Vibe and wanted to use it in Ubuntu 12.04. I was also using Banshee instead of Rhythmbox, and wanted to keep doing that. The problem is that Banshee doesn't detect the device, while Rhythmbox does. However, Rhythmbox crashes when I try to put music on the device... so I got to use Clementine, which works with my device but doesn't work with the music lens.

So... is there a way for me to make Banshee work with that device?

share|improve this question
up vote 3 down vote accepted
  1. Set your player to MTP mode and attach it to your computer with the included USB cable.

  2. Open the file browser and then click on the icon for your player (mine says Philips).

  3. Once your in the window inside your player hit control h (Ctrl+H) (hold the control button and press the "H" key) to show your hidden files.

  4. Right click in the window and select the "Create Document -> Empty File" option.

  5. Name the file: .is_audio_player

  6. Now open the file and paste the following text in it:


    These are a list of directories for the programs to put your music into and a list of the file formats your player supports. I have only included flac and mp3, but you can add others by looking up the mime type syntax (ex wma = audio/x-ms-wma etc).

  7. When you're done, save your file and eject your player.

  8. Let your player update and then plug it back in to your computer.

  9. Open Banshee or Rythmbox and you should see your player mount.

share|improve this answer
Worked like a charm! The device doesn't order the songs by play count, but I think that's a issue with the device itself. – Cmorales Jul 13 '12 at 22:39
I get this error when trying to send files using Rhythmbox: PTP Layer error 2002: add_object_to_cache(): couldn't add object to cache – Cmorales Jul 13 '12 at 23:00

I also was getting same error. I did some research, and lots of tinkering...

Creating the ".is_audio_player" file AND changing the setting on my device to "MSC" transfer mode (saw that in another post someplace) seems to have done the trick! I synced 190+ MP3s using Rhythmbox (ALL my album art and MOST of my tags transferred with no errors).

My setup is an Ubuntu 12.04.1 LTS 64-bit Athlon x2/nVIDIA laptop... and a lowly lil ole Philips GoGear Vibe (4GB) MP3 player.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.