Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log in to the desktop Ubuntu seems to "stutter". Doing pretty much anything causes the cursor to freeze for a few seconds, and the rest of the screen updates something like every 15 seconds (during these 15 seconds I can still move the cursor). For example, opening the home folder I first see no effect, followed by a semi-transparent home folder, and finally the folder as it should be (this can take like 30 seconds); no animation, just three individual frames. Also, I sometimes don't see a window for a program, even though the program in question is supposed to be "up".

Since this is my first experience of Linux, I confess I have no idea where to start - searching the web I only found problems with complete freezes/crashes requiring rebooting, as opposed to this "stuttering".

I installed Ubuntu 12.04 32bit from a bootable USB stick a couple of days ago, right after a fresh Vista 32bit install. Thinking the stuttering might stop if I updated Ubuntu, I managed to install approx 270 updates through the Update Manager, but the stuttering was still there. Apart from the updates, I haven't installed any software other than what was included on the bootable USB stick.

Vista and Ubuntu are on a single Crucial m4 SSD, in a dual-boot setup, with GRUB.
CPU: Intel Core 2 Quad Q6600 GPU: Nvidia GeForce 8800 GTX (with the recommended proprietary drivers)
RAM: 2GB DDR2

share|improve this question
    
Sounds like a problem with the graphics driver. Try selecting "Ubuntu 2D" in the login screen as a (possible) temporary workaround. Then try selecting the other available driver options in the driver selection tool. (It should show up if you type "jockey" into the dash.) –  Béné Jul 2 '12 at 21:17
    
You were absolutely right - Ubuntu 2D gave me the opportunity to change to the other proprietary graphics driver, and now it works! –  Totte Jul 2 '12 at 21:38
    
@Béné you need to post your comment as an answer –  TrailRider Jul 3 '12 at 3:07
    
@Totte you should accept his answer after it it posted if it worked for you, that way other users know that the question was solved. –  TrailRider Jul 3 '12 at 3:07
    
Okay, I added my comment as an answer. Glad it fixed it for you, Totte! –  Béné Jul 3 '12 at 12:01
add comment

1 Answer

up vote 1 down vote accepted

This sounds like a problem with the graphics driver. Try selecting "Ubuntu 2D" in the login screen as a temporary workaround. (How to change to Unity 2D.)

Then try selecting the other available driver options in the driver selection tool. (It should show up if you type "jockey" into the dash.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.