Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question is closely related to other two questions: "How to Add a Shortcut On Desktop" and "How do I add icons to the desktop in 10.04?" (this being a closed question). And I know the answers mentioned there! The problem is it is not working.

I just made a fresh Ubuntu 10.04 install a couple of days ago. Everything works fine for the main user: I can paste anything to the desktop, and it just works.

But I have created another user - as simple as it can be (no special settings; I just created a non-admin user and set its password).

Then, I logged in using this other user account. I just want to create a link for a "Games" folder, for my son, and I simply can't! It doesn't accept "paste", and the right button mouse click does nothing.

I have made several Ubuntu installations, several user accounts, and this never happened to me before! I tried to search some configuration/setting to fix it, but found nothing. I had to use the "Preferences" menu to be able to change the background/wallpaper image.

If I paste files / folders / links to the "Desktop" file system folder, it works (i.e., the files are copied / moved to the "Desktop" folder), but nothing appears in the desktop screen!

And, what impressed me most, I found nothing searching on Google and Ask Ubuntu - I thought this would be a common issue... has anybody experienced this? Any clue to make the desktop just working normally?

Remembering: all works fine for the first user (the admin user created when installing the system).


share|improve this question
up vote 1 down vote accepted

Did you disable showing the desktop? As your regular user that is missing the shortcuts, run gconf-editor. Then navigate to Apps -> nautilus -> preferences and toggle the show_desktop option.

Also, make sure your regular user owns his desktop folder. i.e.

sudo chown -R regularuser:regularuser /home/regularuser/Desktop
share|improve this answer
Well... this is very crazy. I have not disabled showing the desktop and by using the gconf-editor app, the "show_desktop" option was appearing "checked". But, by unchecking it and then checking it back again, then the missing "Games" shorcut appeared in the desktop, which started "working" as I wanted. Problem seems to be solved. Thanks! – J. Bruni Jul 2 '12 at 19:42
Yes! Really solved! I restarted the computer, and the icon remains there, as it should. Thanks a lot! – J. Bruni Jul 2 '12 at 19:47
No problem. I'm glad it worked. I have seen that happen a lot (regardless of OS or application) where something gets mucked up and unsetting/resetting an option causes it to actually set the setting. – reverendj1 Jul 2 '12 at 19:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.