Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently I am using Lubuntu 12.04 desktop installed on my PC. When I play videos, the videos are really slow. It skips frames

I have following PCI devices installed on the system Host bridge : Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)

VGA compatible controller : Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03) (prog-if 00 [VGA controller])

xserver-xorg-video-intel and mesa-utils packages are installed. Direct rendering is enabled. It really doesn't matter if it is enabled or not, both the times the videos are slow almost similarly. While looking for a solution I found a page on intel drivers http://manpages.ubuntu.com/manpages/precise/man4/intel.4.html which deals with Intel graphics drivers.

Is there any way changing the VideoRam to higher value can be helpful? Currently AGP Memory is 128 MB and from the above manpage VideoRam will be set to 8M if AGP >=128MB. 82845G has a AGP memory of 128MB. Is there anyway I can increase VideoRam? I have tried ubuntu with AGP Memory 256MB, where videoRam will be set to 24MB by default, the HD videos are also playing smoothly even though the processor is Intel Celron 1.6Ghz.

Is there anything I can do to increase videoram size? or is this because of something else?

A commentor asked me to attach outputs of dmesg, lsmod, lshw and /var/log/kern.log. 
Here is the output of those commands http://paste.ubuntu.com/1071664/

share|improve this question
    
Isn't there an option in your BIOS to increase the Shared RAM? or you already tried that? –  Uri Herrera Jul 2 '12 at 16:54
    
@UriHerrera, Yes I increased my Shared RAM in BIOS to 128M which is Max in 82845G chipsets, But not change even if I increased or decreased it to 64MB –  Mahesh Bhat Jul 2 '12 at 17:15
add comment

1 Answer 1

Note that the VideoRam setting you mention is only necessary/honored for the i810/815 chipsets; for newer ones, including your i845G, the manpage says:

For the 830M and later, the driver will automatically size  its  memory
allocation  according  to the features it will support.  Therefore, the
VideoRam option, which in the past had been  necessary  to  allow  more
than some small amount of memory to be allocated, is now ignored.

Is there anything I can do to increase videoram size?

Yes, you should be able to increase the AGP aperture size ("graphics memory") in your BIOS (at computer start-up) from 128MB to a larger size. In my experience, that often helps video playback on these old integrated graphics systems.

share|improve this answer
    
In the same man page just above the lines you quoted , these lines exist too 'code' For the 830M and later, this is required in order for the driver to use more video RAM than has been pre-allocated at boot time by the BIOS. This is usually achieved with an "agpgart" or "agp" kernel driver. Linux, FreeBSD, OpenBSD, NetBSD, and Solaris have such kernel drivers available. –  Mahesh Bhat Jul 2 '12 at 17:11
    
Right, but that's a kernel module, not a kernel or module parameter. Please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): /var/log/kern.log, command(s): dmesg, lsmod, sudo lshw –  izx Jul 2 '12 at 17:18
    
here is the output of commands you mentioned paste.ubuntu.com/1071664 –  Mahesh Bhat Jul 2 '12 at 17:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.