Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Has anyone experienced this graphical glitch when typing in Firefox address bar? The drop-down list is not drawn correctly, with some "blocks" missing. After typing more letters or hovering the mouse cursor, the list redraws itself and becomes complete.

I'm running Ubuntu 12.04, Firefox 13.0.1 and this only happens in KDE (tested with 4.8.2, 4.8.3 and 4.8.4). It does not happen in Unity or Xfce with the same user profile.

If I go to the KDE control panel and disable the Fade effect, the bug starts to happen to almost every menu in the system, including, the taskbar window previews. Enabling the “Fade” effect corrects the bug everywhere except in Firefox.

I have an Nvidia card and I am using the proprietary driver (current, not current-updates -- not sure about the difference), but the linked question on an Arch Linux forum says this happen with the open source driver and with other cards too.

Does anyone have an idea for a solution?

enter image description here

share|improve this question
    
What Firefox version are you running? –  Mitch Jul 2 '12 at 14:44
    
Currently it is 13.01, updated automatically, but it had the same bug with the original version that came with Ubuntu 12.04 (was it Firefox 12? 11? I can't remember...) –  marcus Jul 2 '12 at 14:53
    
Try clearing the Cache , or clear recent history option . Or either it seems to be Firfox's integration with KDE , since it is a GTK application, try using KDE style for all GTK applications , it can be found in system-config-gtk-style or kde-config-gtk-style i guess. –  atenz Jul 2 '12 at 17:30
    
I don't think clearing cache and history will work, because Firefox seems completely unaware of this. It behaves as if everything was OK, and the same Firefox installation (and the same profile) works fine in Xfce and Unity. It's most likely a KDE thing. I have tried many Qt and Gtk themes and all exhibit the same behavior. I noticed that when I disable the "Fade" effect in KDE, this bug occurs in other programs too. But Firefox never fades its autocomplete list, so it triggers the bug. –  marcus Jul 2 '12 at 18:59
    
marcus, did you ever file a bug for this? –  Thomas W. Jul 6 '12 at 16:57

2 Answers 2

Marcus, you will need to file a bug for this issue. The easiest route would be from within Firefox. On the the application menu, click Help, then Report Bug. Once you fill out the form, it will be sent to the developers. If you are not able to report a bug this way, there are a few other methods described in the link below:

https://wiki.kubuntu.org/Kubuntu/Bugs/Reporting/

Unfortunately, as with many bugs, the quick and easy fix is to have the developers make an update for this! If you submit your bug in LaunchPad, you may find that other users are also seeing the same glitch, or the developers may point you to a temporary solution until a patch rolls out.

share|improve this answer
    
Thanks, I have reported the bug. I didn't know you could do that from Firefox itself. –  marcus Jul 8 '12 at 22:16
    
Link for the bug report: bugs.launchpad.net/ubuntu/+source/firefox/+bug/1022109 Well, I guess there's nothing else to do now other than wait. –  marcus Jul 12 '12 at 18:07
up vote 0 down vote accepted

It seems I have found a solution. I disabled VSync in the “Desktop Effects” settings panel (sorry for the mixed-language screenshot) and have not seen the glitch ever since. Disable VSync

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.