Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just built a new machine with a Core i5-760 CPU. Max speed is 2.80GHz (turbo mode notwithstanding). I've also done a vanilla install of Ubuntu 10.10.

I've added the cpufreq-selector applet to the top panel, and its menus only allow me to select up to 2.39GHz. If I select the "performance" governor, it also shows 2.39GHz.

cpufreq-info reports:

$ cpufreq-info 
cpufrequtils 007: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to [email protected], please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1.20 GHz - 2.39 GHz
  available frequency steps: 2.39 GHz, 2.26 GHz, 2.13 GHz, 2.00 GHz, 1.86 GHz, 1.73 GHz, 1.60 GHz, 1.46 GHz, 1.33 GHz, 1.20 GHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1.20 GHz and 2.39 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.20 GHz.
  cpufreq stats: 2.39 GHz:13.74%, 2.26 GHz:0.09%, 2.13 GHz:0.08%, 2.00 GHz:0.08%, 1.86 GHz:0.07%, 1.73 GHz:0.07%, 1.60 GHz:0.08%, 1.46 GHz:0.08%, 1.33 GHz:0.11%, 1.20 GHz:85.61%  (15560)
[...CPUs 1-3 elided, but similar...]

Any idea how to get Ubuntu and the various tools to recognise this as a 2.80GHz processor? And ideally to report the actual speed when running in turbo mode too, but that's not critical.

Edit: I should probably add that the BIOS (& Windows) are quite happy that it's a 2.80GHz CPU.

Thanks.

share|improve this question

closed as too localized by fossfreedom Feb 21 '12 at 21:49

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
OK, so I think I'm on to something. My mobo doesn't seem to recognise my memory as 1666, so I've upped my base clock from 133MHz to 160MHz. In order to keep the CPU at 2.80MHz the BIOS has decreased its clock multiplier from 21 to 18. So now I'm running at 18 x 160 (or so) instead of 21 x 133. But... it looks like cpufreq doesn't take the base clock into account. It's seeing the multiplier of 18 and working with the default base clock of 133MHz, and coming up with... 2.39GHz. I'll investigate further. –  dty Dec 2 '10 at 16:23
    
This question seems abandoned, there is no visible activity or information added to it for several months. I have flagged a moderator and am voting for it to be closed. If you feel that the question is not abandoned and that you still suffer from this issue please flag a moderator so that it can be re-opened. –  Bruno Pereira Feb 1 '12 at 19:50

Browse other questions tagged or ask your own question.