Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get this error when I try to authenticate using Gnome GUI. I have NO authentication problem when I use terminal. It is suggested here that I need to do

sudo chown -R myusername:myusername /home/myusername

However this leads to another error

chown: cannot access `/home/myusername/.gvfs': Permission denied

And this happens even if I run the above command as root. I read in launchpad that .gfvs is a FUSE mount point so it can not be manipulated by root. However still have no clue how to fix this.

Appreciate your help.

share|improve this question

1 Answer 1

That error message doesn't mean the command didn't do its job. It's normal for the GNOME VFS mounts folder ~/.gvfs to be impervious to manual changes, since it's perpetually locked and in use (what you read on Launchpad is correct). You could try chowning it without sudo and that might succeed, but really that folder is extremely unlikely to be relevant to the problem you're experiencing. The contents of that folder are not likely to be responsible for any problems authenticating to log in or to perform administrative tasks (including in the Software Center).

If this was your only error message, it probably means that answer didn't work for you, and you'll have to seek other possible solutions to your problem in that question.

share|improve this answer
    
Ok mate .gvfs may not be relevant, but it's really strange. After doing chown, I defined myusername in visudo as a root, but still no cure. –  ublove Jul 2 '12 at 10:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.