Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing a clean xubuntu 12.04 I noticed that when I suspend, the computer suspends and turns itself off (you see the lights go off, and a click sound from the HD or fans), but then about 2 seconds later it turns itself back on again...

The odd thing is that:

  • It doesn't happen when booting from the liveCD
  • I created another user account. When I log onto this account I can suspend fine. The computer stays off until I press the ON button
  • When I remove my .config folder and it's clean - I can also suspend without problem on my account

So it seems that something in my user config is causing this, but I can't work out what it might be. I tried diffing the two .config folders, and also all processes running with one account compared to the other (ps -ef |grep <username>), but couldn't find anything obvious that might be causing this...

UPDATE:

As requested, here's the kern.log - with embeedded comments inside. It shows turning the computer on, logging in as the account that can suspend, suspending successfully, then turning off and on again, this time with my account, suspending (but only for about 2 seconds and then the computer starts again)

and ~/.config contents + dmesg output

share|improve this question
    
I think there is a problem in Ubuntu 12.04 related to power management. Have a look st these threads: askubuntu.com/questions/138367/… bugs.launchpad.net/ubuntu/+source/pm-utils/+bug/990129 In my particular case, I have an HP DV7 laptop with Ubuntu 12.04 If I try to suspend it, the computer enters a continuous loop of suspend - resume until you power off by pressing the button (It is not possible to resume properly again). For me, the only current solution is to wait for any update that solves the problem. –  jap1968 Jul 9 '12 at 10:05
    
Thanks @jap1968, I've seen many threads, but am experiencing something different it seems. I am able to suspend just fine. Just not from my own account though. Only from another account on the same system... Or if I clear my .config folder and start a fresh config –  Yoav Aner Jul 9 '12 at 15:45
    
Please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): /var/log/kern.log, command(s): dmesg, ls -laR ~/.config –  izx Jul 12 '12 at 2:30
    
Thanks @izx - question updated with the information you requested. Hope this helps tracing something... –  Yoav Aner Jul 12 '12 at 8:25
add comment

4 Answers

I looked thoroughly through your log files and couldn't decipher what the issue was. What I would do in your situation is run a script that removes almost all my .config folders, and replaces them one by one as I successfully test the machine in suspend mode. Something like this:

FOLDERS=$(ls .config | grep -v "gtk" -v "gnome") #Use -v to exclude any folders.
for f in "$FOLDERS"; do
     mv "$f" "$f-" #Instead of deleting folders, we just rename them with a hyphen at the end.
done

for f in "$FOLDERS"; do
    echo "Test putting you system to sleep, then press enter to re-enable the next config folder"
    read i #Reads the enter key.
    mv "$f-" "$f"
    echo "Replaced folder: .config/$f"
    echo "$f" > corruptfolder.txt #This file will remember the last folder incase you forget.
done

Note that if you are successful, this script will not finish running (because your computer powered off). You will have correct the folder names that still have a hyphen at the end. Use this loop to do that:

FOLDERS=$(ls .config)
for f in "$FOLDERS"; do
    tmp=$(echo "$f" | sed 's/-$//')
    [ "$tmp" != "$f" ] && mv "$f" "$tmp"
done
share|improve this answer
    
+1 interesting idea, but I don't think it will work. It's not just the contents of the .config folder but what programs / processes must be triggered once I login to the account via X. So to script this process, it's not enough to let the computer resume from suspend -- I would have to manually login each time with a slightly different .config - this will take forever... –  Yoav Aner Jul 29 '12 at 12:19
add comment

exact same symptom - select 'suspend' from the 'gears' icon drop-dwn menu. Result is the same loop to restart describe by OP.

ENV - kernel 3.6.1-030601-generic #201210071322

ENV - Hardware samsung series 9

Orig. OS was 12.04 before the kernel upgrade

Solution - System/settings/power app and tweeked the settings for 'sleep' both on and off the battery. Made sure that there was config val that would request sleep at some threshold regardless of whether mode= battery power or mode=plugged in.

Loop/restart symptom ended after power setting tweeks.

share|improve this answer
    
Thanks for the suggestion. I'm away on holiday so am unable to test it on the computer I was experiencing this problem with. I will definitely give this a try as soon as I can and report back to you if it helped. –  Yoav Aner Dec 15 '12 at 10:26
    
I'm on xubuntu so the power manager applet is a bit different. I tried setting everything that looked like it could be set there, but still having the same problem unfortunately :( –  Yoav Aner Jan 9 '13 at 8:58
add comment

UPDATE: this doesn't work any more. I have no idea why... still experiencing the same issue :(

What solved this eventually for me was turning off the Display Power Management. Go figure why...

On xubuntu, go to Settings->Settings Manager click on Screensaver, Advanced and under Display Power Management untick Power management enabled option.

Since then I am able to suspend without the system going back on :)

share|improve this answer
add comment

I had the same symptom. It disappeared when I changed my nVidia graphics card driver from "version 173-updates" to "version 319"

I am using HP pavilion dv2000 running 12.04 with Kernel Version 3.5.0-43-generic.

share|improve this answer
    
any tips how to check the driver version or upgrade? –  Yoav Aner Nov 14 '13 at 18:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.