Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Now, that Adobe has stopped issuing new releases for Linux desktops, the only option for users is to use Google Chrome, for those who want to use the latest Flash updates. I use Chromium. Is there any way to get Chromium use the Flash from Google Chrome? The reason I as this question is that I have noticed both these browsers run in the background, so technically, the browsers' plugins are available to use.

share|improve this question
1  
Please could you explain what you mean by "both these browsers run in the background" and how that is relevant to using the browsers' plugins? –  user25656 Jul 2 '12 at 3:04
    
unlike previous versions of firefox and google-chrome, latest version of chrome and chromium starts up as soon as you login to the desktop; it then keeps running in the background. so, i was thinking, if there is a way to make use of that and call the Pepper Flash plugin from Chromium. –  Ubuntuser Jul 2 '12 at 23:13
    
Does Chrome start as soon as you login because you have "Continue running background apps when Google Chrome is closed" ticked in Chrome's settings (advanced)? See this for an image. –  user25656 Jul 3 '12 at 2:24
    
yes it is. but thats not my concern. i was asking if we can use the latest flash pluin from Chrome. –  Ubuntuser Jul 3 '12 at 13:11

6 Answers 6

up vote 12 down vote accepted

Download Google Chrome and extract libpepflashplayer.so from /opt/google/chrome/PepperFlash in the Chrome deb file Copy libpepflashplayer.so to /usr/lib/chromium-browser/plugins Make the necessary changes to the Chromium startup

sudo gedit /etc/chromium-browser/default

Add this to the CHROMIUM_FLAGS

CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/chromium-browser/plugins/libpepflashplayer.so --ppapi-flash-version=11.5.31.2"

You can get the correct version of the flash plugin from the "version": json tag in the mainfest.json from /opt/google/chrome/PepperFlash in the Chrome deb file

share|improve this answer
    
Any tip to check what flash player am I running? :) –  s3m3n Nov 5 '13 at 16:42

There in no need to use flash from Google Chrome. You can simply install it from command line.

sudo apt-get install flashplugin-installer

Wait until finished. Then restart your browser and enjoy.

share|improve this answer
    
thats not what i am asking for. please read the whole question –  Ubuntuser Jul 1 '12 at 23:53
2  
There are now two Flash plug-ins: one, the one obtained by using the command you suggest, will have only security updates. The other, Pepper Flash, is provided by Google along with each installation of Google Chrome and will have security updates and new or improved features. What OP wants to do is to have the Chromium browser use this second plug-in. –  user25656 Jul 2 '12 at 3:09

Try copying the libflashplayer.so from /opt/google/chrome/PepperFlash to /usr/lib/chromium-browser/plugins.

share|improve this answer
1  
unfortunately, it didnt work! :) –  Ubuntuser Jul 7 '12 at 9:35

This worked great for me: http://www.webupd8.org/2012/09/how-to-make-chromium-use-flash-player.html

It's similar to Craig's answer but with help for the "flags" part.

share|improve this answer
2  
Nice! Please add a summary to your answer, just in case anything happens to the external link. –  carnendil Apr 18 '13 at 17:57

A recent answer that works! I am adding extra characters to get to 30.... http://www.webupd8.org/2014/01/pepper-flash-player-installer-for.html

share|improve this answer
    
Please instead of providing just a link post the directions here. Thanks –  Wild Man Apr 19 at 21:29

Google Chrome's flash player Pepper Flash is now in Ubuntu reposistories (Ubuntu 14.04). You can install it running the following commands:

sudo apt-get install pepperflashplugin-nonfree
sudo update-pepperflashplugin-nonfree --install

Restart Crhomium.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.