Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not sure where to start with this one.

I've installed Gnome 3 by running sudo apt-get install gnome on my netbook, it all installed fine and ran fine didn't have any issues with it for a few weeks, then I turned on my netbook and logged in to be given the look and feel of Gnome 2.

I've cropped down the desktop in the image below.

Gnome 3 Desktop

Edit: Pastebinit as requested by izx

kern.log

dmesg

sudo lshw

share|improve this question
    
may be your nvidia card driver have set to turn the composite extension off so that it can work fine. –  user118125 Jan 2 '13 at 7:24
    
@Amod The reason this was happening to me is because the nVidia drivers were installed but there is no nVidia card in the system. askubuntu.com/questions/158297/… –  Nalum Jan 4 '13 at 11:24

1 Answer 1

up vote 12 down vote accepted

Let's try the simple way to fix it first, because that looks like the Gnome3 Classic look (which is, yes, very similar to Gnome2)

  1. Open a terminal, and type/paste:

    sudo apt-get update && sudo apt-get --reinstall install gnome-shell
    
  2. Logout

  3. Click on the Ubuntu logo:

    enter image description here

  4. Select the Gnome session, and click back:

    enter image description here

  5. Login and see if you still get the Gnome2 look-and-feel.

share|improve this answer
    
Thanks for the answer, I have done this and it didn't fix the issue. When I log in now I am still getting the Gnome3 Classic look and now my resolution is locked at 640x480. –  Nalum Jul 1 '12 at 13:41
1  
You are falling back to 2D because your 3D is disabled, possibly because your graphics drivers are broken. Please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): /var/log/kern.log, command(s): dmesg, sudo lshw –  izx Jul 1 '12 at 13:44
    
I've added the pastebinit links to the question. –  Nalum Jul 1 '12 at 15:37
    
@Nalum, why is the nvidia driver being loaded although you have no nvidia card? (see dmesg lines 919-921) –  izx Jul 1 '12 at 16:24
    
no idea why that is there. so if I uninstall that it should hopefully fix the issue? –  Nalum Jul 1 '12 at 18:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.