Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm building an application that uses tweepy (a python library) and when I build it on my local machine it works fine. When I submit it to launchpad though, it sent me a log which has this error: ERROR: Python module tweepy not found.

I found a ppa python-tweepy on Launchpad.

So how do I fix this error.

The log from Launchpad is here.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You should add the tweepy PPA as dependency for your PPA (you can do this from the Launchpad web interface for your PPA), and add python-tweepy as a build dependency in your package.

share|improve this answer
    
Thanks for your answer... but I still get the same error... log is at launchpadlibrarian.net/109452102/… –  qw3rty_rocks Jul 6 '12 at 9:41
    
Where is your source package? Is tweepy actually in the list of build dependencies? –  jelmer Jul 6 '12 at 14:32
    
You can try adding tweepy to the control file in your debian folder of your application, in the build dependencies section. –  Jobi Carter Jul 6 '12 at 21:16
    
found my problem here (in troubleshooting section) –  qw3rty_rocks Jul 7 '12 at 2:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.