Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I found Google Chrome running as service after I installed it, at each reboot. This would not be a problem, if it won't eath 100% cpu. I would not like to uninstall it, but I'll be forced to do that if I can't find a way to disable its remain in memory as a service.

I couldn't find anything in Boot-Up-Manager, so I'm asking where to search...

share|improve this question
    
How do you know that it runs as service? Can you show some evidence. –  mikewhatever Jul 1 '12 at 8:01
    
In system monitor I see the process as chrome --type=service –  jasmines Jul 1 '12 at 8:27
    
Possible Duplicate askubuntu.com/questions/19320/… –  Mitch Jul 1 '12 at 10:49

3 Answers 3

I had cloud print enabled which caused it. Try disconnecting any cloud print printers you may be sharing from this computer. In vasa1's pic, if you're sharing any printers, under Google Cloud Print, instead of 'Add Printers' there will be a button for disconnecting printers. Hit that and then also make sure you have background apps unchecked (off).

share|improve this answer

Do you have "Continue running background apps when Google Chrome is closed" ticked? If so, try unticking the box and then remove Google Chrome from the Startup Menu.

Also check to see if you have any sort of "notifications" such as GMail or messaging that may be causing the browser to be "always on".

Background apps

share|improve this answer
    
It seems this did not help. Both services readd themselves to start apps upon reboot... –  jasmines Jul 16 '12 at 7:37
    
I'm editing my answer to include the notifications part. –  user25656 Jul 16 '12 at 7:47
    
How can I be sure that GMail notification (I do have it in autostart) is responsible of Chrome and Chromium start as services and moreover, how can I get rid of this behaviour? –  jasmines Jul 29 '12 at 6:04
    
I don't use GMail notifications. Could you temporarily uninstall it to see if the problem goes away and that way at least be sure what is the source of your problem? Still, it's very unusual that something should take 100% CPU usage and it's indicative of something not working as it should! Unfortunately, the format of Ask Ubuntu doesn't seem to favor prolonged discussion so troubleshooting is difficult. You could sign up at ubuntuforums.org which is a bit less restrictive. –  user25656 Jul 29 '12 at 6:41
    
I removed GMail notifications from autostart, but after a few reboots, Chromium service added itself again to autostart apps. –  jasmines Aug 1 '12 at 12:54

Type this command s in terminal

cd /etc/xdg/autostart/

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

And do a reboot , click the top Right-Corner Settings icon , to select Startup Applications.

enter image description here

If Google Chrome is present in list there , just Unselect to stop Autostarting it.

share|improve this answer
1  
They show there again if I disable their autostart. See above. –  jasmines Jul 29 '12 at 6:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.