Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have experienced 2-3 unexplained lockup over last 10 days.

Today, I had a random lockup (no mouse, keyboard response, 100% CPU). But, when I finally switched (Ctrl-Alt-F1) to command line (it took several minutes) it told me that thunderbird-bin had locked a CPU.

I ran this to resolve:

pidof thunderbird-bin
sudo kill ####

However, after saving other work, I tried restarting Thunderbird. It went to 90%+ CPU, and within 20 seconds it locked again.

Once I have more detail I will raise a bug (on Ubuntu Forums).

Does anyone have any other suggestions, advice?

UPDATE: (Sep-2012)

Thunderbird 13.0.1 is quite stable in safe mode. Still working to resolve ..


UPDATE 2: (Jan-2013)

Now running Thunderbird 17.0.2 (Ubuntu 12.04).

Still have ALL Plugins disabled. Works well, and does everything I need.

Not attempting to resolve.

share|improve this question
    
May be same issue as: ubuntuforums.org/showthread.php?p=12063541 –  david6 Jul 1 '12 at 1:03
    
Maybe related to: bugzilla.mozilla.org/show_bug.cgi?id=787348 –  Guy Korland Sep 23 '12 at 9:43
    
Not sure. With Plugins mostly disabled (which I don't use anyway) it is no longer an issue. –  david6 Sep 23 '12 at 10:01
add comment

3 Answers 3

Have you tried hiding the status bar? ( View->Toolbar->Status bar ) For me it seems that the animated progress bar uses vast amounts of CPU.

share|improve this answer
add comment

Change the configuration key

mail.db.idle_limit

to

30000000

In Preferences->Advanced->General->Config-editor

Source: http://rainbow.chard.org/2013/02/19/thunderbird-high-cpu/

share|improve this answer
add comment

Another solution that also works is to

unset LC_ALL

before you launch thunderbird. Previously, I've set mine to "C" to convert the times to a 24H format, but it seems to have quite some performance overhead.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.