Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Kubuntu 12.04 on my netbook. Each time I invoke the Firefox Installer, it downloads a package, and nothing happens.

Thanks for help in advance.

share|improve this question
What are you trying to do? Show us the commands that you are using. – Lucio Jun 30 '12 at 23:37
had the same issue Kubuntu 12.04 seems to ship with a lot of software sources disabled by default. enable through muon and let it update sources then install as per usual good luck – user180447 Aug 1 '13 at 12:08

If you want to install software graphically in Kubuntu you need to use an application called Muon. You can also install packages from the command line by opening a terminal and typing, for the example related to your question, sudo apt-get install firefox. sudo tells the computer you want to do the following action with administrative privileges, apt-get is an application to install software and firefox is the name of the package you want to install. The terminal will ask for your password and, once you give it, apt-get will do the rest.

share|improve this answer
Thanks a lot, I did it using the apt-get command and it worked perfectly. – Eeesy Jul 2 '12 at 19:29

When you said "invoking the Firefox installer", do you mean downloading it on their website?

If it is the case, Firefox is into the package you downloaded. Unpack the package (with the archive manager, for example) and you will find a folder called "firefox" containing the program.

share|improve this answer
The package "Firefox installer" was already available after I installed kubuntu from the scratch. I was wondering, why only an "installer" was provided. Anyway, the installation with the apt-get command worked well. Thanks for help! – Eeesy Jul 2 '12 at 19:28

protected by Community Aug 1 '13 at 14:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.