Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Some Type 1 fonts, particularly URW Palladio L, look rather ugly when rendered on-screen in various programs. In particular, the letter height is inconsistent. See the body text below, rendered in Firefox:

Screenshot of Firefox

The header text is Nimbus Sans L, also a Type 1 font; in this sample, it's looking acceptable, but sometimes its baseline isn't clean.

I have this problem in most programs. OpenOffice and AbiWord both display it with URW Palladio. I similarly have problems with Nimbus Sans embedded in PDFs displayed in Evince.

Any suggestions as to how to fix this? Settings I can tweak somewhere to make it work properly?

share|improve this question
    
I think they're just poorly-kerned fonts. Though, Firefox and Open Office have their own built-in font rendering engines instead of using the system-wide ones (because they are cross-platform apps). And Evince uses Poppler... I'd file bugs with upstream font designers about the bad kerning. –  maco Dec 6 '10 at 18:24
    
I assume you've experimented with the rendering settings on the font tab of System>Preferences>Appearance? –  misterben Dec 7 '10 at 22:59
    
@misterben Yep, some at least. There is probably another permutation or two I can try. –  Michael Ekstrand Dec 7 '10 at 23:14
    
@misterben I tried a few more permutations, and found that the default "Subpixel" setting actually does fix it in AbiWord, etc. That just left the issue of Firefox; turns out that Firefox actually uses ~/.fonts.conf, which was set to medium rather than slight hinting. URW Palladio doesn't hint well at medium. Nimbus Sans still has a messed-up baseline, though. If you want to write up an answer, I can accept it unless someone comes w/ a great answer that fixes Nimbus Sans too. –  Michael Ekstrand Dec 7 '10 at 23:32
    
I've added an answer. It may be worth you adding detail of your ~/.fonts.conf changes for the benefit of anyone reading this question later, as it's not as easy to work out as the GUI rendering settings. –  misterben Dec 8 '10 at 9:32

1 Answer 1

up vote 2 down vote accepted
+25

Tinkering with the rendering settings on the font tab of System>Preferences>Appearance should let you fine-tune the appearance. The hinting (instructions on how to best suggest the shape of the letters at low resolution) on some fonts doesn't work well with the default settings.

This Ubuntu Wiki entry has some explanation of font settigns in Ubuntu.

share|improve this answer
2  
To complete the change, I had to edit ~/.fonts.conf to set the hintstyle assignment to hintslight. URW Palladio does not hint well with medium hinting (which is unfortunate, since I prefer the medium-hinted aesthetic for everything else). –  Michael Ekstrand Dec 8 '10 at 15:38
    
That's weird - I thought accepting the answer was enough to issue the bounty. I guess I was supposed to issue it separately for full credit to happen. –  Michael Ekstrand Dec 18 '10 at 0:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.