Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The brightness of the whole screen goes down considerably when I enlarge windows with a dark background (Gnome-terminal and TTYs for example, as well as Games, especially when in fullscreen). It's up to a point sometimes that the text on TTYs is only barely visible. The brightness goes up again if I put other windows (like a regular Firefox-window) in front or when I make the "problematic" windows smaller. It also happens if a Browsser-window shows lots of dark/black background, but it seems that the effect is more severe the more of that darkness is shown.

I use Ubuntu 12.04 and nVidia-drivers 302.17 (problem occured for many months, with 11.10 and older nVidia-drivers as well).

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This sounds like it's your monitor. Some monitors have a feature called "dynamic contrast" which basically adjusts the backlight based on what's on the screen. This way they can claim in their advertising that it has a ridiculously high contrast ratio. It may look nice in some places, depending on your preference.

You can probably turn this off. Fiddle with the controls on your monitor and there should be something about dynamic contrast in the menu. (On my Samsung T240, the option is under Picture / MagicBright).

share|improve this answer
    
It was indeed my monitor, ty. That "Dynamic Contrast" option was hidden within a menu named "MagicBright" (a Samsung monitor). –  Mrokii Jun 30 '12 at 22:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.