Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Before upgrading to 10.10, I was able to execute a binary in my home directory simply by double-clicking it. Now when I double-click it, I am told that no program is installed to run that type of file.

Here is my attempt to make it run via the command line.

~/blender25$ ls -l
total 37272
-rwxr-xr-x 1 mac9416 mac9416 38076379 2010-04-22 00:58 blender
-rw-r--r-- 1 mac9416 mac9416     5716 2009-06-18 12:31 copyright.txt
-rw-r--r-- 1 mac9416 mac9416    17992 2010-02-12 11:31 GPL-license.txt
drwxr-xr-x 6 mac9416 mac9416     4096 2010-02-12 13:24 icons
drwxr-xr-x 5 mac9416 mac9416     4096 2010-02-18 11:59 plugins
-rw-r--r-- 1 mac9416 mac9416     2396 2009-06-18 12:31 Python-license.txt
-rw-r--r-- 1 mac9416 mac9416     6441 2010-03-09 00:39 readme.html
~/blender25$ uname -m
x86_64
~/blender25$ file blender
blender: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, not stripped
~/blender25$ ./blender 
bash: ./blender: No such file or directory

As you can see, the file certainly exists, yet I am told that it does not.

This has happened with another binary; but with the other one I was given a permissions error. Running chmod +x on it got me past that error, but I still get "No such file or directory".

So, what is preventing execution of these binaries in my directory in 10.10?

share|improve this question
    
This is very strange. What are the permission on the files? Can you give use the result of a 'ls -l' rather than just the result of 'ls'. –  Nyamiou The Galeanthrope Dec 2 '10 at 7:59
    
Please provide the output from the following command: uname -m; file blender –  João Pinto Dec 2 '10 at 9:45
    
Thanks for your questions! I've updated the command line output to include your commands. –  mac9416 Dec 2 '10 at 14:39

2 Answers 2

up vote 5 down vote accepted

You are trying to run a 32bit binary on a 64bit system:

The output of uname -m, x86_64, means that you're running a 64Bit system. However, the blender binary is a 32bit Binary: blender: ELF 32-bit LSB executable, Intel 80386 ....

The fact that bash says the file doesn't exist seems to be a bug that never got fixed, since I get the same message when I attempt to run a 64Bit binary on my 32Bit system.

share|improve this answer
    
Thanks for your answer! That seems likely enough to be the problem except that the same binary worked fine before I upgraded from 10.04 (and, of course, the architecture has not changed). Still, I will try a 64-bit binary and let you know how it goes. –  mac9416 Dec 2 '10 at 17:22
1  
I believe there is a package that allows you to run 32Bit binaries on a 64Bit system... you might have to install that first. –  user2817 Dec 2 '10 at 17:28
    
The 64-bit binary works, so this is the correct answer. Why the 32-bit binary stopped working, I don't know. I haven't found that package yet, but if I do I'll let you know how it goes. Thanks! –  mac9416 Dec 23 '10 at 14:59

I had something like that happen to me once. It turned out it was a caching issue for the file system. Is the ~/blender folder on a different file system than the main one? (I presume that you have tried rebooting your computer)

share|improve this answer
    
Yes, I've rebooted. My home directory is on its own partition, encrypted. –  mac9416 Dec 2 '10 at 14:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.