Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install a 27KB lens( reddit-lens: here ) & this "apt-get update" is going to download 20MBs(!) of data for the same. I want to avoid this update bcoz i am on a limited bandwidth connection.

I also tried to install .deb file(27KB) for this lens but it says "dependancy is not satisfiable gir1.2-unity-3.0". I went on to http://www.pkgs.org to get that package & there is no version available for ubuntu 12.04.

What should I do? Can i install softwares without updating cache? Is that update necessary? Also installation of some softwares requires updating cache while others dont, why?

share|improve this question
    
Possible duplicate? askubuntu.com/questions/117157/… –  fossfreedom Jun 30 '12 at 15:13
    
@fossfreedom: I don't think so. –  David Halter Jun 30 '12 at 22:16
add comment

2 Answers 2

up vote 0 down vote accepted

The .deb file listed on http://www.webupd8.org/2011/04/install-unity-reddit-lens-in-ubuntu-deb.html is for Ubuntu 11.04. Developments since that version of Ubuntu mean that this is no longer compatible with more recent versions of Ubuntu.

The following files are available for more recent versions of Ubuntu:

Ubuntu 12.04:

https://code.launchpad.net/~markjtully/+archive/ppa/+build/3441964/+files/unity-reddit-lens_0.4-0%7E15%7Eprecise1_all.deb

Ubuntu 11.10:

https://code.launchpad.net/~gorzka/+archive/precise/+build/3129477/+files/unity-reddit-lens_0.3-0%7E7%7Eoneiric1_all.deb

share|improve this answer
add comment

The packages for ubuntu are all also available under http://archive.ubuntu.org.

Your desired package might be here: http://us.archive.ubuntu.com/ubuntu/pool/main/libu/libunity/

I personally don't think this will be enough to resolve the dependency stuff. But you could certainly try it.

share|improve this answer
    
I got that package but now software center says "gir1.2-unity-3.0 conflicts with the installed gir1.2-unity-5.0" –  Rohan Jul 1 '12 at 3:27
    
yeah, that's what I meant with "I personally don't think this will be enough to resolve the dependency stuff". Probably you just have to use apt-get update somehow (and maybe upgrade some stuff). However, you have the option to turn off some sources (look at ubuntu software center -> edit -> software sources and turn of multiverse and universe or turn them off in /etc/apt/sources.list). Maybe this helps to reduce the update data. –  David Halter Jul 2 '12 at 9:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.