Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So here's the deal. I'm new to apache and just installed it today. I got the dirs setup and when I type my IP address (from my ISP) into a browser it pulls up the site fine, but when I try to access it from outside my home network using the same IP I get a 404 not found. I've got port forwarding setup on my router for port 80 and my I checked with my ISP to make sure they didn't block port 80 incoming connections. Any ideas would be greatly appreciated.

share|improve this question
    
Alright, So I tried a different port even though my ISP said they didn't block em... they lied. Solution found, but I'll give the correct answer to TheX for responding so fast ;) –  Bryan Dec 2 '10 at 2:41
add comment

2 Answers

up vote 0 down vote accepted

Try putting the IP address in DMZ (Demilitarized Zone).

For me it looks like this:

alt text

share|improve this answer
add comment

It may not be your ISP. if you're on cable/dsl log into your modem's properties. Most of them now-adays come pre-equipped with a firewall as well. I had to disable the firewall on my Motorola Surfboard cable modem to serve up my own Port 80 content.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.