Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried with several guides, but no one worked out.

The last one was http://ubuntuforums.org/showpost.php?p=3697702&postcount=5.
It seemed to be good, but when i run the ./configure command it says:

checking for GCC version... ./configure: eval: line 4919: syntax error near unexpected token `)'
./configure: eval: line 4919: `my_compiler_version=4.6.3-1ubuntu5)'

How can I get my audio working?

share|improve this question
    
do you have gcc? sudo apt-get install gcc to install it –  Web-E Jun 30 '12 at 11:48
    
I have gcc already installed. I think there is a error in the patch... –  BearLikeOthers Jun 30 '12 at 11:50
    
I found this info on my audio harware with lspci -v : 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03) Subsystem: Apple Inc. Device 00a0 Flags: bus master, fast devsel, latency 0, IRQ 46 Memory at d0600000 (64-bit, non-prefetchable) [size=16K] Capabilities: <access denied> Kernel driver in use: snd_hda_intel Kernel modules: snd-hda-intel –  BearLikeOthers Jun 30 '12 at 16:04
add comment

1 Answer

Download and install the latest DKMS. This will resolve your issues (as it did mine with my Macbook Pro 17" early 2008).

Here is a link: alsa-hda-dkms_0.201210170702~precise1_all.deb

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.