Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Because of skype sound issues I was told to replace pulseaudio with alsa. I only found a solution for Ubuntu 10.10.

Does this still work for Ubuntu 12.04 Precise Pangolin?
Or does it still not make any sense to replace pulseaudio with alsa (as Jorge Castro said in his comment)?
Or should I stick to pulseaudio AND alsa?
I don't want to mess up my system. Thanks!

share|improve this question
    
You should definitely stick with pulseaudio AND alsa. I haven't used skype too much, so I can't exactly give suggestions on fixing that though. Sorry! –  MiJyn Jul 19 '12 at 2:20
    
@lkjoel Thanks for the comment. Can you explain me why I should stick to both? –  Filbuntu Jul 19 '12 at 6:28
5  
Nearly all components in Ubuntu work with pulseaudio (with ALSA being the backend). I have had no problems with Skype audio with Pulseaudio + ALSA, so all I can say is that you can fix your problem using both :) –  MiJyn Jul 19 '12 at 17:57
    
If you really want to remove pulseaudio, you can try this (I haven't tested using 12.04): idyllictux.wordpress.com/2009/04/21/… –  MiJyn Jul 19 '12 at 17:58
    
@lkjoel Thanks for the further info. I don't really want to remove pulseaudio that is why I asked the question, but want to get a solution for my sound problems. It would be helpful to hear from somebody that tested the removing pulseaudio in Ubuntu 12.04. –  Filbuntu Jul 23 '12 at 4:59

2 Answers 2

up vote 2 down vote accepted

This seems to work, though you must understand that it isn't replacing pulseaudio with alsa but just removing pulseaudio(the front-end).

sudo apt-get autoremove pulseaudio

However alsa still needs a graphical user interface for you to easily communicate with it say goodbye to the easy integrated indicator that Ubuntu comes with

sudo apt-get install gnome-alsamixer

You can also do all of this in the Ubuntu Software Centre.

share|improve this answer
    
try this... It seems to have worked for my computer. askubuntu.com/questions/157891/… –  UbuntuHusker Nov 13 '12 at 18:14
    
Thanks a lot for the answer. As my sound problems are solved at the moment, I won't test to remove front-end pulseaudio :-). But the answer is probably helpful to somebody else and so that person can acknowledge it. –  Filbuntu Nov 19 '12 at 5:16

I solved my problem after months and months of not being able to get it working properly. The only way I could get the mic to work with Skype was to switch off Pulse by setting 'autospawn=off', and then I'd lose my lovely desktop volume control, until:- I discovered that this laptop has "stereo, or mono" input via the built in microphone (sorry, can't remember which), but the solution was to open pavucontrol, split the channels on the input (microphone) and reduce the volume of one of the channels to zero. Works perfectly, haven't had a problem since. I now use Alsa and Pulse, all normal and I have all the useful sound controls of pulse with the alsa backend.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.