Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just installed Ubuntu 12.04 (Precise) and am using it on my TV. The HDMI sound doesn't work.

All I have installed is:

  • The preinstalled codecs and other software,
  • a KDE game called KsirK,
  • Supertuxkart,
  • and GIMP 2.8.

I am using a custom built computer, and a LG TV. My processor is Pentium(R) Dual-Core CPU E5200 @ 2.50GHz dual core, OS is 32-bit, and I have 1.7GB of ram (after having to remove one stick due to failure). I am also running Windows Xp on the computer.

share|improve this question
    
Have you tried a search here for 'HDMI'? Try a few of the answers and if that does not help please update your question with some specifics. –  Tom Brossman Jun 30 '12 at 7:29
    
Possible dublicate: askubuntu.com/questions/148636/… –  FuzzyQ Jun 30 '12 at 7:29
    
I have given you my specifics –  Gubuntu Jul 1 '12 at 15:08
    
When I say specifics I mean 'What troubleshooting steps from similar questions have you taken', and 'How is your issue different from other 'HDMI not working' questions'? I'd like to help you get better answers by adding this info to your question. –  Tom Brossman Jul 2 '12 at 21:08
    
I have tried a terminal command that fixes mp4 playback bug for gstreamer at a website I can't remember. The way my issue is different from the others is that their problems happened after they installed something, where as my problem was right from when ubuntu was installed. –  Gubuntu Jul 3 '12 at 16:54

3 Answers 3

HDMI output is muted by default (at least on my laptop). Open the Sound Settings (click the speaker icon on the top panel to get to the settings). In the Output tab, an HDMI output should appear when the hdmi cable is connected. Select this, then adjust the volume slider at the bottom of the window.

share|improve this answer
    
Tried that before you said. Still doesn't work. –  Gubuntu Jun 30 '12 at 11:23

It may vary depending on your Laptop/PC environment. Some older HW hadn't got audio via HDMI, but SPIDF instead. Like HP DV2700

share|improve this answer
    
computer is about 1 year old and has latest sound card for when it was built. It has worked on a previous Ubuntu version before that Ubuntu crashed. Is also running Windows XP 32-bit. The pc is completely custom. I didn't make it though, my friend did. –  Gubuntu Jun 30 '12 at 11:27

Try installing the newest Kernel 3.5 from http://www.kernel.org/ (choose the right version, 32 or 64 bit). Reboot and see if that works. I did that with my laptop and fixed my sound problem. If it doesn't work, you can always delete it from the sypnatics package manager, assuming you have installed that from the software center.

share|improve this answer
2  
How would an upstream kernel (from kernel.org) have been installed from the Software Center??? Did you use a PPA? –  Eliah Kagan Jul 2 '12 at 21:37
    
I agree with Eliah Kagan. What good would downloading the latest kernel do? Surely, if I needed it ubuntu would update it for me. –  Gubuntu Jul 4 '12 at 19:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.