Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the same problem as described in the questions skype notification sounds sizzled and bad sound on login to skype. But it is not only the login, notification, but also when talking to somebody. I tried the solution to remove/re-install skype and most of the solutions in this questions, e.g. checking mixer, sound settings and installing alsa-hda-dkms (incl. system restart).
After installing skype (and even after upgrade to skype 4.0) in Ubuntu 12.04 (AMD 64) there was no sound at all. I followed the first step of the SoundTroubleshootingProcedure and at least there is now sound:

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa; sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

The jittering sound would sometimes disappear, e.g. on the Echo-Testcall after replaying the recorded part. And I noticed that if I let music play in the rhythmbox and then start skype, the sound is fine. So I have a weak solution, but I would be glad it would work without this detour.

In VLC when I play, restart after pause I have to same jittering sound.

As requested: My sound card is a an "AMD High Definition Audio Device" called Advanced Micro Devices (AMD) Hudson Azalia controller (rev01), subsystem Lenovo Device 21ea (according to sysinfo) on a Lenovo Thinkpad Edge 525.

share|improve this question
1  
if you dual-boot with windows then you can try skype there so see if it's a hardware issue. Is it? –  Alvar Jun 30 '12 at 10:53
    
@Alvar I don't have dual boot and will not have it on this computer. But I had Ubuntu 11.04 installed on the same computer before installing 12.04 and skype worked out of the box/repositories. I even had not to do step 1 of the SoundTroubleshootingProcedure to get any sound, it just worked without sizzle. –  Filbuntu Jun 30 '12 at 12:22
add comment

7 Answers 7

up vote 82 down vote accepted

It's not just a problem with Skype, I believe it's a problem with, you've guessed it, PulseAudio.

Workaround? Indeed there is.

Disabling PulseAudio's Glitch Free Audio seems to have solved the crackling for me (which became unbearable on Ubuntu 12.10 Beta 2)

To do this, edit the /etc/pulse/default.pa file in your favourite text editor.

Search for the following line:

load-module module-hal-detect

and append "tsched=0" to the end:

load-module module-hal-detect tsched=0

restart pulse (or just reboot your system), and the crackling should be gone.

Not sure what the side effects are by disabling Glitch Free Audio, but I can't seem to find any yet.

UPDATE: If you don't have a line with load-module module-hal-detect, then search for following line:

load-module module-udev-detect  

and append "tsched=0" to the end:

load-module module-udev-detect tsched=0

restart pulse (or just reboot your system), and the crackling should be gone.

share|improve this answer
    
Thanks a lot, it helped at least 5 people, unfortunately not me :-(. There is no load-module module-hal-detect in the file /etc/pulse/default.p on my system. The closest are the lines ### Use the static hardware detection module (for systems that lack udev/hal support) load-module module-detect, so I added tsched=0 to the last line. But no change. I added another line with load-module module-hal-detect tsched=0 and then with the same line, but deleted load-module module-detect, too. Unfortunately all this did not let disappear any sizzling after restart. Any tip left? –  Filbuntu Oct 19 '12 at 7:32
3  
try replacing that whole section with the following: ### Automatically load driver modules depending on the hardware available .ifexists module-udev-detect.so load-module module-udev-detect tsched=0 .else ### Use the static hardware detection module (for systems that lack udev/hal support) load-module module-detect .endif –  Robert Ian Hawdon Oct 19 '12 at 22:51
    
I tried again, just added tsched=0 to the line with module-udev-detect and it works (hopefully for ever :-). Before I copied & pasted what you wrote, but probably some spaces at the end of the lines or something else I missed caused me to have no sound ("dummy output" & no input). –  Filbuntu Oct 20 '12 at 2:37
3  
This did the trick on Ubuntu 12.10 (module-udev-detect). Abba's Greatest hits/ Dancing Queen (The first in my collection) now pumping out nicely! –  AndyM Oct 31 '12 at 11:46
1  
Thanks, that fixed it for me too. Glitch free audio should be renamed to "glitch audio". Pulse is soooo problematic. Looking forward to a descent sound system in Linux. –  Matt H Dec 5 '12 at 21:04
show 6 more comments

The solution provided above by Robert worked for me. I had updgraded to 12.10 ubuntu and the new skype 4.0 upgrade had unusable sound (scratchy and distorted). editing per the instructions above and appending the following line to: load-module module-hal-detect tsched=0 in the /etc/pulse/default.pa file resolved the issue perfectly.

For awareness, the upgrade to 12.10 caused the recognition of my Soundblaster card to fail to be the default. For some reason it now defaulted to thinking my NVIDIA graphics card was the default sound card. Skype would initially make NO sound.
This can be corrected by following the directions in the Ubuntu forums post by billesboelle July 27, 2008. Here repeated for inclusiveness: I can't get Ubuntu to default select the pci card, after trying the settings from complete soundprob guide as below:
It seems the index=0 function doesn't want to help me. Maybe its due to the fact that my machine registres 2 sound drivers with same name ? cat /proc/asound/modules gives this response:

0 snd_hda_intel  
1 snd_hda_intel  
2 snd_cmipci  

Any ideas,or something you wanna see before being able to help me. Btw, forgot to mention. If i try the index option, my pci can is removed from aplay -l and cat /proc/asound/modules.

Configuring default soundcards / stopping multiple soundcards from switching Note: This section assumes that you have installed each soundcard properly.

In a shell, type

    cat /proc/asound/modules 

This will give the the name and index of each sound card you have currently. Make a note of the names, and decide which one you want to be the default card.

Now type

    sudo nano /etc/modprobe.d/alsa-base

At the very end of the file, add the following (assuming you have 3 cards with module names A, B and C and you want to have them in the order CAB)

options snd-C index=0  
options snd-A index=1  
options snd-B index=2
share|improve this answer
add comment

If you suspect that it's pulseaudio causing you the problems, there might be an easier fix for you. I posted an article with step by step directions on my blog on how to fix bad sound in Ubuntu. This is a fix for Wine, but since it's a modification of a pulseaudio configuration file, it might be applicable to other similar problems.

share|improve this answer
    
Thanks! I hoped it would work, but it did not :-( for me (default-fragment-size-msec set to 5 and 3, no difference). Although I saw that it worked for Xell . –  Filbuntu Jul 24 '12 at 4:54
    
Thanks, that did the trick for me on Ubuntu 14.04! –  Chris Jun 23 at 22:32
add comment

Had the same issue on Archlinux. Turned out pulseaudio was causing this. Getting rid of pulseaudio restored clear sound in Skype for me. For Gnome-based distros like mainline Ubuntu it is probably impossible to remove pulseaudio since it is a dependency for most of the gnome stuff, including gdm, but on kubuntu, xubuntu and lubuntu this might actually work since they initially don't come with pulseaudio and the gnome bloatware, and if it got installed most likely it happened as a dependency for some other package that depends on gnome or its libraries.

share|improve this answer
1  
Has someone tried to get rid of pulseaudio in Ubuntu 12.04? And did it help to improve skype sound problems without any side-effects? If yes and yes, please tell us how you did it in this question –  Filbuntu Jun 30 '12 at 9:25
add comment

I just removed pulseaudio from ubuntu 12.04 on my toshiba p875-s7200 and it fixed skype beautifully! sound went from crap to awesome :) note: I had to install alsa-hda-dkms to get sound at all on this laptop

share|improve this answer
1  
Thanks! Can you give a step-by-step instruction how you did it here? –  Filbuntu Jul 23 '12 at 5:18
add comment

This worked for me, ubuntu 12.10 /64, mb asus m4a785tdv-evo amd64 (audio VIA VT1708S)

edited the /etc/pulse/default.pa (sudo pico /etc/pulse/default.pa)

could not find load-module module-hal-detect

so i just edited the line load-module module-udev-detect, so to have :

load-module module-udev-detect tsched=0

saved changes and restarted the system. Now Skype seems fine. until now I had problems when using Skype with crackling/echo/noise which sometimes adjusted/stopped during the conversation (sometimes it fixed when closing the web browser) but sometimes it kept going all the time heavily compromising the conversation. Skype apparently was the only situation with audio problems for me.

share|improve this answer
1  
Thanks for your efforts, but it seems that this answer is already part of the most rated (edited) answer (askubuntu.com/a/201747/30631). –  Filbuntu Jan 9 '13 at 1:31
add comment

You should check your internet connection (http://www.speedtest.net for speed test).

Also, as it works after RyhthmBox you could also try to update drivers (for sound card).

It could also help other answerers if you told us what kind of sound card you have in your computer.

share|improve this answer
    
Thanks for that, but the internet speed has not changed after switching from 11.10 to 12.04, it is still not great (DSL 768Kbps download :-(, but it worked fined so far, no sound problems like this. –  Filbuntu Jun 30 '12 at 9:31
    
How do I know whether I have the latest driver? How do you update an AMD sound card? jockey-gtk only reveals a graphic card. (perhaps this will be another askubuntu-question) –  Filbuntu Jun 30 '12 at 9:35
add comment

protected by Community May 18 '13 at 15:19

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.