Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

how can I re-enable panel shadow for both top and bottom? CCSM doesn't seems to work for me. Any ideas?

share|improve this question
    
What have you done in CompizConfig Settings Manager that didn't work? –  Stefano Palazzo Dec 2 '10 at 0:37
    
ive installed rgba before , since then , my panel does not have shadow even ive reset my ccsm =( –  Wilsonzaizai Dec 2 '10 at 0:38
1  
In the CCSM, try to navigate to Effects → Window Borders (maybe it's window decorations) and set the value for "Shadow for Windows" to "all". Does that do anything? You should also try to log out afterwards. –  Stefano Palazzo Dec 2 '10 at 3:58
    
doesnt work =( any terminal tricks for this ? –  Wilsonzaizai Dec 2 '10 at 6:23
    
I algo got the same problem after installing GNOME Color Chooser. I think the better idea is unistall it. –  user9783 Jan 28 '11 at 15:26
show 1 more comment

2 Answers

Make sure compiz is activated, then launch ccsm and go to Window Decoration (make sure it is activated too) and on Shadow windows type any (if you only want shadows on panel but not on windows, type type=Dock). If it is still not working, reset all the value in Window Decoration, just make sure Shadow windows = any. If it is still not working, go to Window Rules and make sure it is unactivated.

And if it still not working, make sure compiz is really activated and in ccsm go to Preferences and click on Reset to defaults, that will reset all the parameters of Compiz so if you have a lot of customs parameters you will lost all of them and will have to make them again but it will almost certainly solve the problem.

share|improve this answer
    
"Shadow windows = any" works for me (ubuntu 11.04 Gnome classic). –  quangtruong1985 Aug 16 '11 at 5:55
add comment

If you are using ccsm, try adding Class=gnome-panel to the windows option for decorations. Usually enabling rgba does not affect shadows.

I'm also going to guess you are using emerald? If you are, install emerald-theme-manager, and modify the theme so that shadows are visible again.

If you provide more information I will update my answer to suit.

share|improve this answer
    
it doesnt help either =( –  Wilsonzaizai Dec 2 '10 at 6:17
    
ok , ccsm doesnt work at all , tried purge ppa to revert back also , nothing changed , its just the gnome panel does not hav any shadows , others are ok , just the gnome-panel =( –  Wilsonzaizai Dec 2 '10 at 6:22
    
You didn't mention a ppa in your question. Can you please provide more information? –  RolandiXor Dec 2 '10 at 15:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.